Skip to content

← Actionable
High, CVSS 8.8

Agent-to-controller access control allowed writing to sensitive directory used by Jenkins Pipeline: Shared Groovy Libraries Plugin

CVE-2021-21696GHSA-c5r9-rx53-q3gf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jenkins-ci.main:jenkins-core 2.319, 2.303.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2021-21696: 2.40% estimated exploitation activity in the next 30 days; percentile 84.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Jenkins 2.318 and earlier, LTS 2.303.2 and earlier does not limit agent read/write access to the libs/ directory inside build directories when using the FilePath APIs. This directory is used by the Pipeline: Shared Groovy Libraries Plugin to store copies of shared libraries. This allows attackers in control of agent processes to replace the code of a trusted library with a modified variant, resulting in unsandboxed code execution in the Jenkins controller process. Jenkins 2.319, LTS 2.303.3 prohibits agent read/write access to the libs/ directory inside build directories. If you are unable to immediately upgrade to Jenkins 2.319, LTS 2.303.3, you can install the Remoting Security Workaround Plugin. It will prevent all agent-to-controller file access using FilePath APIs. Because it is more restrictive than Jenkins 2.319, LTS 2.303.3, more plugins are incompatible with it. Make sure to read the plugin documentation before installing it. It is not easily possible to customize the file…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-c5r9-rx53-q3gf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-21696

Advisory: Agent-to-controller access control allowed writing to sensitive directory used by Jenkins Pipeline: Shared Groovy Libraries Plugin
IDs: CVE-2021-21696, GHSA-c5r9-rx53-q3gf
Record: https://patchnext.com/advisories/cve-2021-21696 (revision 1, source checked 26 Oct 2026, 16:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.jenkins-ci.main:jenkins-core 2.319, 2.303.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.jenkins-ci.main:jenkins-core: affected >= 2.304, <= 2.318; <= 2.303.2; fixed in 2.319, 2.303.3

## Suggested inspection (read-only)
- Maven org.jenkins-ci.main:jenkins-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.jenkins-ci.main:jenkins-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-c5r9-rx53-q3gf (GitHub-reviewed advisory GHSA-c5r9-rx53-q3gf lists affected ranges: Maven org.jenkins-ci.main:jenkins-core >=2.304 =0 <=2.303.2)

Commands are suggestions: review each one before running it.

Loading voting…