Skip to content

← Actionable
Medium, CVSS 4.3

Missing Authorization in Jenkins S3 publisher Plugin

CVE-2021-21650GHSA-fvfc-8pqr-wjpv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jenkins-ci.plugins:s3 0.11.7, 0.11.5.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2021-21650: 0.71% estimated exploitation activity in the next 30 days; percentile 53.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Jenkins S3 publisher Plugin prior to 0.11.7 and 0.11.5.1 does not perform Run/Artifacts permission checks in various HTTP endpoints and API models. This allows attackers with Item/Read permission to obtain information about artifacts uploaded to S3, if the optional Run/Artifacts permission is enabled. Jenkins S3 publisher Plugin 0.11.7 and 0.11.5.1 requires Run/Artifacts permission to obtain information about artifacts if this permission is enabled.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-fvfc-8pqr-wjpv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-21650

Advisory: Missing Authorization in Jenkins S3 publisher Plugin
IDs: CVE-2021-21650, GHSA-fvfc-8pqr-wjpv
Record: https://patchnext.com/advisories/cve-2021-21650 (revision 1, source checked 26 Oct 2026, 16:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.jenkins-ci.plugins:s3 0.11.7, 0.11.5.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.jenkins-ci.plugins:s3: affected >= 0.11.6, <= 0.11.6; < 0.11.5.1; fixed in 0.11.7, 0.11.5.1

## Suggested inspection (read-only)
- Maven org.jenkins-ci.plugins:s3: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.jenkins-ci.plugins:s3.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-fvfc-8pqr-wjpv (GitHub-reviewed advisory GHSA-fvfc-8pqr-wjpv lists affected ranges: Maven org.jenkins-ci.plugins:s3 >=0.11.6 =0 <0.11.5.1)

Commands are suggestions: review each one before running it.

Loading voting…