Missing permission checks in Jenkins CloudBees AWS Credentials Plugin allows enumerating credentials IDs
CVE-2021-21625GHSA-jwr9-h4jm-c9ch
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.jenkins-ci.plugins:aws-credentials 1.28.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.jenkins-ci.plugins:aws-credentials
- Affected
- <= 1.28
- Fixed in
- 1.28.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jwr9-h4jm-c9ch lists affected ranges: Maven org.jenkins-ci.plugins:aws-credentials >=0 <=1.28
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2021-21625: 0.75% estimated exploitation activity in the next 30 days; percentile 54.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
CloudBees AWS Credentials Plugin 1.28 and earlier does not perform a permission check in a helper method for HTTP endpoints. This allows attackers with Overall/Read permission to enumerate credentials IDs of AWS credentials stored in Jenkins if any of the following plugins are installed: - Amazon Elastic Container Service (ECS) / Fargate - AWS Parameter Store Build Wrapper - AWS SAM\n\nFurther plugins may use this helper method as well without performing a permission check themselves. Credentials IDs obtained this way can be used as part of an attack to capture the credentials using another vulnerability. CloudBees AWS Credentials Plugin 1.28.1 performs permission checks in the helper method for HTTP endpoints.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-jwr9-h4jm-c9ch
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-21625 Advisory: Missing permission checks in Jenkins CloudBees AWS Credentials Plugin allows enumerating credentials IDs IDs: CVE-2021-21625, GHSA-jwr9-h4jm-c9ch Record: https://patchnext.com/advisories/cve-2021-21625 (revision 1, source checked 26 Oct 2026, 16:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.jenkins-ci.plugins:aws-credentials 1.28.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.jenkins-ci.plugins:aws-credentials: affected <= 1.28; fixed in 1.28.1 ## Suggested inspection (read-only) - Maven org.jenkins-ci.plugins:aws-credentials: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.jenkins-ci.plugins:aws-credentials. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jwr9-h4jm-c9ch (GitHub-reviewed advisory GHSA-jwr9-h4jm-c9ch lists affected ranges: Maven org.jenkins-ci.plugins:aws-credentials >=0 <=1.28) Commands are suggestions: review each one before running it.
Loading voting…