Backport for CVE-2021-21024 Blind SQLi from Magento 2
CVE-2021-21427GHSA-fvrf-9428-527m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (openmage/magento-lts 20.0.9, 19.4.13), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist openmage/magento-lts
- Affected
- <= 19.4.12>= 20.0.0, <= 20.0.8
- Fixed in
- 19.4.13, 20.0.9
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fvrf-9428-527m lists affected ranges: Packagist openmage/magento-lts >=0 =20.0.0 <=20.0.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2021-21427: 1.07% estimated exploitation activity in the next 30 days; percentile 65.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact This vulnerability allows an administrator unauthorized access to restricted resources. We fixed a vulnerability in the MySQL adapter to prevent SQL injection attacks. This is a backport of CVE-2021-21024 https://helpx.adobe.com/security/products/magento/apsb21-08.html. Patches Has the problem been patched? What versions should users upgrade to? v20.0.9 v19.4.13
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fvrf-9428-527m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-21427 Advisory: Backport for CVE-2021-21024 Blind SQLi from Magento 2 IDs: CVE-2021-21427, GHSA-fvrf-9428-527m Record: https://patchnext.com/advisories/cve-2021-21427 (revision 1, source checked 26 Oct 2026, 14:01 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: openmage/magento-lts 20.0.9, 19.4.13. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist openmage/magento-lts: affected <= 19.4.12; >= 20.0.0, <= 20.0.8; fixed in 19.4.13, 20.0.9 ## Suggested inspection (read-only) - Packagist openmage/magento-lts: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on openmage/magento-lts. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fvrf-9428-527m (GitHub-reviewed advisory GHSA-fvrf-9428-527m lists affected ranges: Packagist openmage/magento-lts >=0 =20.0.0 <=20.0.8) Commands are suggestions: review each one before running it.
Loading voting…