Skip to content

← Actionable
Critical, CVSS 9.8

Fixes a bug in Zend Framework's Stream HTTP Wrapper

CVE-2021-21426GHSA-m496-x567-f98c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openmage/magento-lts 20.0.9, 19.4.13), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2021-21426: 1.20% estimated exploitation activity in the next 30 days; percentile 68.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact CVE-2021-3007: Backport of ZendHttpResponseStream, added certain type checking as a way to prevent exploitation. https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-3007 This vulnerability is caused by the unsecured deserialization of an object. In versions higher than Zend Framework 3.0.0, the attacker abuses the Zend3 feature that loads classes from objects in order to upload and execute malicious code in the server. The code can be uploaded using the “callback” parameter, which in this case inserts a malicious code instead of the “callbackOptions” array. Patches Has the problem been patched? What versions should users upgrade to? v20.0.9 v19.4.13

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-m496-x567-f98c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-21426

Advisory: Fixes a bug in Zend Framework's Stream HTTP Wrapper
IDs: CVE-2021-21426, GHSA-m496-x567-f98c
Record: https://patchnext.com/advisories/cve-2021-21426 (revision 1, source checked 26 Oct 2026, 14:01 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openmage/magento-lts 20.0.9, 19.4.13. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist openmage/magento-lts: affected <= 19.4.12; >= 20.0.0, <= 20.0.8; fixed in 19.4.13, 20.0.9

## Suggested inspection (read-only)
- Packagist openmage/magento-lts: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openmage/magento-lts.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-m496-x567-f98c (GitHub-reviewed advisory GHSA-m496-x567-f98c lists affected ranges: Packagist openmage/magento-lts >=0 =20.0.0 <=20.0.8)

Commands are suggestions: review each one before running it.

Loading voting…