Prevent user enumeration using Guard or the new Authenticator-based Security
CVE-2021-21424GHSA-5pv8-ppvj-4h68
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (symfony/maker-bundle 1.31.1, 1.29.2; lexik/jwt-authentication-bundle 2.11.3, 2.10.7; symfony/symfony 5.2.9, 4.4.24, 3.4.49; symfony/security-http 5.2.8; symfony/security-core 5.2.8, 4.4.23, 3.4.48; 2 more packages under Affected packages), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist symfony/maker-bundle
- Affected
- >= 1.27.0, < 1.29.2>= 1.30.0, < 1.31.1
- Fixed in
- 1.31.1, 1.29.2
Packagist lexik/jwt-authentication-bundle
- Affected
- >= 2.0.0, < 2.10.7>= 2.11.0, < 2.11.3
- Fixed in
- 2.11.3, 2.10.7
Packagist symfony/symfony
- Affected
- >= 2.8.0, < 3.4.49>= 4.0.0, < 4.4.24>= 5.0.0, < 5.2.9
- Fixed in
- 4.4.24, 5.2.9, 3.4.49
Packagist symfony/security-http
- Affected
- >= 5.1.0, < 5.2.8
- Fixed in
- 5.2.8
Packagist symfony/security-core
- Affected
- >= 2.8.0, < 3.4.48>= 4.0.0, < 4.4.23>= 5.0.0, < 5.2.8
- Fixed in
- 4.4.23, 3.4.48, 5.2.8
Packagist symfony/security
- Affected
- >= 5.0.0, < 5.2.8>= 2.8.0, < 3.4.49>= 4.0.0, < 4.4.24
- Fixed in
- 4.4.24, 5.2.8, 3.4.49
Packagist symfony/security-guard
- Affected
- >= 2.8.0, < 3.4.48>= 4.0.0, < 4.4.23>= 5.0.0, < 5.2.8
- Fixed in
- 4.4.23, 3.4.48, 5.2.8
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5pv8-ppvj-4h68 lists affected ranges: Packagist symfony/security >=5.0.0 =2.8.0 =4.0.0 =2.8.0 =4.0.0 =5.0.0 =2.8.0 =4.0.0 =5.0.0 =2.0.0 =2.11.0 =1.27.0 =1.30.0 =5.1.0…
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2021-21424: 1.64% estimated exploitation activity in the next 30 days; percentile 76.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description ----------- The ability to enumerate users was possible without relevant permissions due to different exception messages depending on whether the user existed or not. It was also possible to enumerate users by using a timing attack, by comparing time elapsed when authenticating an existing user and authenticating a non-existing user. Resolution ---------- We now ensure that 403s are returned whether the user exists or not if the password is invalid or if the user does not exist. The patch for this issue is available here for branch 3.4. Credits ------- I would like to thank James Isaac and Mathias Brodala for reporting the issue and Robin Chalas for fixing the issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5pv8-ppvj-4h68
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-21424 Advisory: Prevent user enumeration using Guard or the new Authenticator-based Security IDs: CVE-2021-21424, GHSA-5pv8-ppvj-4h68 Record: https://patchnext.com/advisories/cve-2021-21424 (revision 1, source checked 26 Oct 2026, 14:18 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: symfony/maker-bundle 1.31.1, 1.29.2; lexik/jwt-authentication-bundle 2.11.3, 2.10.7; symfony/symfony 5.2.9, 4.4.24, 3.4.49; symfony/security-http 5.2.8; symfony/security-core 5.2.8, 4.4.23, 3.4.48; symfony/security 5.2.8, 4.4.24, 3.4.49; symfony/security-guard 5.2.8, 4.4.23, 3.4.48. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist symfony/maker-bundle: affected >= 1.27.0, < 1.29.2; >= 1.30.0, < 1.31.1; fixed in 1.31.1, 1.29.2 - Packagist lexik/jwt-authentication-bundle: affected >= 2.0.0, < 2.10.7; >= 2.11.0, < 2.11.3; fixed in 2.11.3, 2.10.7 - Packagist symfony/symfony: affected >= 2.8.0, < 3.4.49; >= 4.0.0, < 4.4.24; >= 5.0.0, < 5.2.9; fixed in 4.4.24, 5.2.9, 3.4.49 - Packagist symfony/security-http: affected >= 5.1.0, < 5.2.8; fixed in 5.2.8 - Packagist symfony/security-core: affected >= 2.8.0, < 3.4.48; >= 4.0.0, < 4.4.23; >= 5.0.0, < 5.2.8; fixed in 4.4.23, 3.4.48, 5.2.8 - Packagist symfony/security: affected >= 5.0.0, < 5.2.8; >= 2.8.0, < 3.4.49; >= 4.0.0, < 4.4.24; fixed in 4.4.24, 5.2.8, 3.4.49 - Packagist symfony/security-guard: affected >= 2.8.0, < 3.4.48; >= 4.0.0, < 4.4.23; >= 5.0.0, < 5.2.8; fixed in 4.4.23, 3.4.48, 5.2.8 ## Suggested inspection (read-only) - Packagist symfony/maker-bundle: check the installed version with your package manager. - Packagist lexik/jwt-authentication-bundle: check the installed version with your package manager. - Packagist symfony/symfony: check the installed version with your package manager. - Packagist symfony/security-http: check the installed version with your package manager. - Packagist symfony/security-core: check the installed version with your package manager. - Packagist symfony/security: check the installed version with your package manager. - Packagist symfony/security-guard: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on symfony/maker-bundle, lexik/jwt-authentication-bundle, symfony/symfony, symfony/security-http, symfony/security-core, symfony/security, symfony/security-guard. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5pv8-ppvj-4h68 (GitHub-reviewed advisory GHSA-5pv8-ppvj-4h68 lists affected ranges: Packagist symfony/security >=5.0.0 =2.8.0 =4.0.0 =2.8.0 =4.0.0 =5.0.0 =2.8.0 =4.0.0 =5.0.0 =2.0.0 =2.11.0 =1.27.0 =1.30.0 =5.1.0…) Commands are suggestions: review each one before running it.
Loading voting…