ApiKey secret could be revelated on network issue
CVE-2021-21421GHSA-xw22-wv29-3299
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (node-etsy-client 0.3.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm node-etsy-client
- Affected
- <= 0.2.0
- Fixed in
- 0.3.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xw22-wv29-3299 lists affected ranges: npm node-etsy-client >=0 <0.3.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xw22-wv29-3299 lists affected ranges: npm node-etsy-client >=0 <=0.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H
- EPSS
- CVE-2021-21421: 1.06% estimated exploitation activity in the next 30 days; percentile 64.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact What kind of vulnerability is it? Who is impacted? Applications that are using node-etsy-client and reporting client error to the end user will offer api key value too Patches Has the problem been patched? What versions should users upgrade to? creharmony/node-etsy-client#18 fixes this issue. This is fixed in node-etsy-client v0.3.0 and later. Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? Do not report or log etsy client error if you are using version <= v0.2.0 Update your version of node-etsy-client References Are there any links users can visit to find out more? - https://github.com/creharmony/node-etsy-client/issues/17 : On connect error secret appears in error #17 For more information If you have any questions or comments about this advisory: Open an issue in github.com/creharmony/node-etsy-client/issues
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-xw22-wv29-3299
- Revision 1 · created ·
Published from osv record GHSA-xw22-wv29-3299
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-21421 Advisory: ApiKey secret could be revelated on network issue IDs: CVE-2021-21421, GHSA-xw22-wv29-3299 Record: https://patchnext.com/advisories/cve-2021-21421 (revision 2, source checked 26 Oct 2026, 12:17 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: node-etsy-client 0.3.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm node-etsy-client: affected <= 0.2.0; fixed in 0.3.0 ## Suggested inspection (read-only) - `npm ls node-etsy-client --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on node-etsy-client. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-xw22-wv29-3299 (OSV record GHSA-xw22-wv29-3299 lists affected ranges: npm node-etsy-client >=0 <0.3.0 (fixed)) - Verified: https://github.com/advisories/GHSA-xw22-wv29-3299 (GitHub-reviewed advisory GHSA-xw22-wv29-3299 lists affected ranges: npm node-etsy-client >=0 <=0.2.0) Commands are suggestions: review each one before running it.
Loading voting…