Skip to content

← Actionable
High, CVSS 7.7amended

Command injection vulnerability in @prisma/sdk in getPackedPackage function

CVE-2021-21414GHSA-pxcc-hj8w-fmm7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@prisma/sdk 2.20.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.7 · CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:N
EPSS
  • CVE-2021-21414: 2.07% estimated exploitation activity in the next 30 days; percentile 81.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact As of today, we are not aware of any Prisma users or external consumers of the @prisma/sdk package who are affected by this security vulnerability. This issue may lead to remote code execution if a client of the library calls the vulnerable method with untrusted input. It only affects the getPackedPackage function and this function is not advertised and only used for tests & building our CLI, no malicious code was found after checking our codebase. Patches Fixed in - @prisma/sdk@2.20.0 (latest channel) - @prisma/sdk@2.20.0-dev.29 (dev channel) Pull Request closing this vulnerability https://github.com/prisma/prisma/pull/6245 Acknowledgements This issue was discovered and reported by GitHub Engineer @erik-krogh (Erik Krogh Kristensen). For more information If you have any questions or comments about this advisory: - Create a discussion in the Prisma repository - Email us at security@prisma.io

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-pxcc-hj8w-fmm7

  2. Revision 1 · created ·

    Published from osv record GHSA-pxcc-hj8w-fmm7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-21414

Advisory: Command injection vulnerability in @prisma/sdk in getPackedPackage function
IDs: CVE-2021-21414, GHSA-pxcc-hj8w-fmm7
Record: https://patchnext.com/advisories/cve-2021-21414 (revision 2, source checked 26 Oct 2026, 12:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @prisma/sdk 2.20.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @prisma/sdk: affected < 2.20.0; fixed in 2.20.0

## Suggested inspection (read-only)
- `npm ls @prisma/sdk --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @prisma/sdk.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-pxcc-hj8w-fmm7 (OSV record GHSA-pxcc-hj8w-fmm7 lists affected ranges: npm @prisma/sdk >=0 <2.20.0 (fixed))
- Verified: https://github.com/advisories/GHSA-pxcc-hj8w-fmm7 (GitHub-reviewed advisory GHSA-pxcc-hj8w-fmm7 lists affected ranges: npm @prisma/sdk >=0 <2.20.0)

Commands are suggestions: review each one before running it.

Loading voting…