Skip to content

← Actionable
High, CVSS 8.0amended

Misuse of Reference and other transferable APIs may lead to access to nodejs isolate

CVE-2021-21413GHSA-mmhj-4w6j-76h7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (isolated-vm 4.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.0 · CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:N
EPSS
  • CVE-2021-21413: 0.72% estimated exploitation activity in the next 30 days; percentile 53.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Versions of isolated-vm before v4.0.0, and especially before v3.0.0, have API pitfalls which may make it easy for implementers to expose supposed secure isolates to the permissions of the main nodejs isolate. Reference objects allow access to the underlying reference's full prototype chain. In an environment where the implementer has exposed a Reference instance to an attacker they would be able to use it to acquire a Reference to the nodejs context's Function object. Similar application-specific attacks could be possible by modifying the local prototype of other API objects. Access to NativeModule objects could allow an attacker to load and run native code from anywhere on the filesystem. If combined with, for example, a file upload API this would allow for arbitrary code execution. To address these issues the following changes were made in v4.0.0: - Documentation was updated with more explicit guidelines on building secure applications. - Reference instances will no longer follow…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-mmhj-4w6j-76h7

  2. Revision 1 · created ·

    Published from osv record GHSA-mmhj-4w6j-76h7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-21413

Advisory: Misuse of `Reference` and other transferable APIs may lead to access to nodejs isolate
IDs: CVE-2021-21413, GHSA-mmhj-4w6j-76h7
Record: https://patchnext.com/advisories/cve-2021-21413 (revision 2, source checked 26 Oct 2026, 12:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: isolated-vm 4.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm isolated-vm: affected < 4.0.0; fixed in 4.0.0

## Suggested inspection (read-only)
- `npm ls isolated-vm --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on isolated-vm.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mmhj-4w6j-76h7 (OSV record GHSA-mmhj-4w6j-76h7 lists affected ranges: npm isolated-vm >=0 <4.0.0 (fixed))
- Verified: https://github.com/advisories/GHSA-mmhj-4w6j-76h7 (GitHub-reviewed advisory GHSA-mmhj-4w6j-76h7 lists affected ranges: npm isolated-vm >=0 <4.0.0)

Commands are suggestions: review each one before running it.

Loading voting…