[thi.ng/egf] Potential arbitrary code execution of #gpg-tagged property values
CVE-2021-21412GHSA-rj44-gpjc-29r7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@thi.ng/egf 0.4.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @thi.ng/egf
- Affected
- < 0.4.0
- Fixed in
- 0.4.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-rj44-gpjc-29r7 lists affected ranges: npm @thi.ng/egf >=0 <0.4.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rj44-gpjc-29r7 lists affected ranges: npm @thi.ng/egf >=0 <0.4.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- EPSS
- CVE-2021-21412: 1.34% estimated exploitation activity in the next 30 days; percentile 71.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Potential for arbitrary code execution in #gpg-tagged property values (only if decrypt: true option is enabled) Patches A fix has already been released as v0.4.0 Workarounds By default, EGF parse functions do NOT attempt to decrypt values (since GPG is only available in non-browser env). However, if GPG encrypted values are used/required: 1. Perform a regex search for #gpg-tagged values in the EGF source file/string and check for backtick (\) chars in the encrypted value string 2. Replace/remove them or skip parsing if present... References https://github.com/thi-ng/umbrella/security/advisories/GHSA-rj44-gpjc-29r7#advisory-comment-65261 For more information If you have any questions or comments about this advisory, please open an issue in the thi.ng/umbrella repo, of which this package is part of.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-rj44-gpjc-29r7
- Revision 1 · created ·
Published from osv record GHSA-rj44-gpjc-29r7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-21412 Advisory: [thi.ng/egf] Potential arbitrary code execution of `#gpg`-tagged property values IDs: CVE-2021-21412, GHSA-rj44-gpjc-29r7 Record: https://patchnext.com/advisories/cve-2021-21412 (revision 2, source checked 26 Oct 2026, 12:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @thi.ng/egf 0.4.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @thi.ng/egf: affected < 0.4.0; fixed in 0.4.0 ## Suggested inspection (read-only) - `npm ls @thi.ng/egf --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @thi.ng/egf. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-rj44-gpjc-29r7 (OSV record GHSA-rj44-gpjc-29r7 lists affected ranges: npm @thi.ng/egf >=0 <0.4.0 (fixed)) - Verified: https://github.com/advisories/GHSA-rj44-gpjc-29r7 (GitHub-reviewed advisory GHSA-rj44-gpjc-29r7 lists affected ranges: npm @thi.ng/egf >=0 <0.4.0) Commands are suggestions: review each one before running it.
Loading voting…