Authentication Bypass by Primary Weakness in github.com/kongchuanhujiao/server
CVE-2021-21403GHSA-8wrg-m8vm-5fvj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/kongchuanhujiao/server 1.3.21), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/kongchuanhujiao/server
- Affected
- < 1.3.21
- Fixed in
- 1.3.21
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8wrg-m8vm-5fvj lists affected ranges: Go github.com/kongchuanhujiao/server >=0 <1.3.21
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2021-21403: 1.36% estimated exploitation activity in the next 30 days; percentile 71.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Authentication Bypass by Primary Weakness (CWE-305) Commit: https://github.com/kongchuanhujiao/server/commit/9a125624f219e496bdf4b07b404816d5a309bdc1 ALL Users is impacted. Patches Yes, PLEASE UPGRADE TO v1.3.21-beta.d0ffc0a6
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-8wrg-m8vm-5fvj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-21403 Advisory: Authentication Bypass by Primary Weakness in github.com/kongchuanhujiao/server IDs: CVE-2021-21403, GHSA-8wrg-m8vm-5fvj Record: https://patchnext.com/advisories/cve-2021-21403 (revision 1, source checked 26 Oct 2026, 14:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/kongchuanhujiao/server 1.3.21. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/kongchuanhujiao/server: affected < 1.3.21; fixed in 1.3.21 ## Suggested inspection (read-only) - Go github.com/kongchuanhujiao/server: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/kongchuanhujiao/server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8wrg-m8vm-5fvj (GitHub-reviewed advisory GHSA-8wrg-m8vm-5fvj lists affected ranges: Go github.com/kongchuanhujiao/server >=0 <1.3.21) Commands are suggestions: review each one before running it.
Loading voting…