nanopb vulnerable to invalid free() call with oneofs and PB_ENABLE_MALLOC
CVE-2021-21401GHSA-7mv5-5mxh-qg88
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (nanopb 0.4.5, 0.3.9.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI nanopb
- Affected
- >= 0.3.2, < 0.3.9.8>= 0.4.0, < 0.4.5
- Fixed in
- 0.3.9.8, 0.4.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7mv5-5mxh-qg88 lists affected ranges: PyPI nanopb >=0.3.2 =0.4.0 <0.4.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7mv5-5mxh-qg88 lists affected ranges: PyPI nanopb >=0.3.2 =0.4.0 <0.4.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2021-21401: 1.81% estimated exploitation activity in the next 30 days; percentile 78.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Decoding a specifically formed message can cause invalid free() or realloc() calls if the message type contains an oneof field, and the oneof directly contains both a pointer field and a non-pointer field. If the message data first contains the non-pointer field and then the pointer field, the data of the non-pointer field is incorrectly treated as if it was a pointer value. Such message data rarely occurs in normal messages, but it is a concern when untrusted data is parsed. Patches Preliminary patch is available on git for 0.4.x and 0.3.x branches. The fix will be released in versions 0.3.9.8 and 0.4.5 once testing has been completed. Workarounds Following workarounds are available: Set the option nounions for the oneof field. This will generate fields as separate instead of C union, and avoids triggering the problematic code. Set the type of all fields inside the oneof to FTPOINTER. This ensures that the data contained inside the union is always a valid pointer. Heap…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-7mv5-5mxh-qg88
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-7mv5-5mxh-qg88
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-21401 Advisory: nanopb vulnerable to invalid free() call with oneofs and PB_ENABLE_MALLOC IDs: CVE-2021-21401, GHSA-7mv5-5mxh-qg88 Record: https://patchnext.com/advisories/cve-2021-21401 (revision 3, source checked 26 Oct 2026, 13:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: nanopb 0.4.5, 0.3.9.8. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI nanopb: affected >= 0.3.2, < 0.3.9.8; >= 0.4.0, < 0.4.5; fixed in 0.3.9.8, 0.4.5 ## Suggested inspection (read-only) - `python -m pip show nanopb`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on nanopb. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7mv5-5mxh-qg88 (OSV record GHSA-7mv5-5mxh-qg88 lists affected ranges: PyPI nanopb >=0.3.2 =0.4.0 <0.4.5 (fixed)) - Verified: https://github.com/advisories/GHSA-7mv5-5mxh-qg88 (GitHub-reviewed advisory GHSA-7mv5-5mxh-qg88 lists affected ranges: PyPI nanopb >=0.3.2 =0.4.0 <0.4.5) Commands are suggestions: review each one before running it.
Loading voting…