Denial of service (via resource exhaustion) due to improper input validation on groups/communities endpoints
CVE-2021-21393GHSA-jrh7-mhhx-6h88
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (matrix-synapse 1.28.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI matrix-synapse
- Affected
- < 1.28.0
- Fixed in
- 1.28.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jrh7-mhhx-6h88 lists affected ranges: PyPI matrix-synapse >=0 <1.28.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jrh7-mhhx-6h88 lists affected ranges: PyPI matrix-synapse >=0 <1.28.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.0 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2021-21393: 1.60% estimated exploitation activity in the next 30 days; percentile 75.77 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Missing input validation of some parameters on the groups (also known as communities) endpoints could cause excessive use of disk space and memory leading to resource exhaustion. Additionally clients may have issues rendering large fields. Patches This issue is fixed by #9321 and #9393. Workarounds The groups feature can be disabled (by setting enablegroupcreation to False) to mitigate this issue. Note that it is disabled by default. Other information Note that the groups feature is not part of the Matrix specification and the chosen maximum lengths are arbitrary. Not all clients might abide by them.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-jrh7-mhhx-6h88
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-jrh7-mhhx-6h88
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-21393 Advisory: Denial of service (via resource exhaustion) due to improper input validation on groups/communities endpoints IDs: CVE-2021-21393, GHSA-jrh7-mhhx-6h88 Record: https://patchnext.com/advisories/cve-2021-21393 (revision 3, source checked 26 Oct 2026, 13:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: matrix-synapse 1.28.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI matrix-synapse: affected < 1.28.0; fixed in 1.28.0 ## Suggested inspection (read-only) - `python -m pip show matrix-synapse`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on matrix-synapse. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jrh7-mhhx-6h88 (OSV record GHSA-jrh7-mhhx-6h88 lists affected ranges: PyPI matrix-synapse >=0 <1.28.0 (fixed)) - Verified: https://github.com/advisories/GHSA-jrh7-mhhx-6h88 (GitHub-reviewed advisory GHSA-jrh7-mhhx-6h88 lists affected ranges: PyPI matrix-synapse >=0 <1.28.0) Commands are suggestions: review each one before running it.
Loading voting…