Misinterpretation of malicious XML input
CVE-2021-21366GHSA-h6q6-9hqw-rwfv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (xmldom 0.5.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm xmldom
- Affected
- < 0.5.0
- Fixed in
- 0.5.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-h6q6-9hqw-rwfv lists affected ranges: npm xmldom >=0 <0.5.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h6q6-9hqw-rwfv lists affected ranges: npm xmldom >=0 <0.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
- EPSS
- CVE-2021-21366: 1.34% estimated exploitation activity in the next 30 days; percentile 71.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact xmldom versions 0.4.0 and older do not correctly preserve system identifiers, FPIs or namespaces when repeatedly parsing and serializing maliciously crafted documents. This may lead to unexpected syntactic changes during XML processing in some downstream applications. Patches Update to 0.5.0 (once it is released) Workarounds Downstream applications can validate the input and reject the maliciously crafted documents. References Similar to this one reported on the Go standard library: - https://mattermost.com/blog/coordinated-disclosure-go-xml-vulnerabilities/ For more information If you have any questions or comments about this advisory: Open an issue in xmldom/xmldom Email us: send an email to all addresses that are shown by npm owner ls xmldom
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-h6q6-9hqw-rwfv
- Revision 1 · created ·
Published from osv record GHSA-h6q6-9hqw-rwfv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-21366 Advisory: Misinterpretation of malicious XML input IDs: CVE-2021-21366, GHSA-h6q6-9hqw-rwfv Record: https://patchnext.com/advisories/cve-2021-21366 (revision 2, source checked 26 Oct 2026, 12:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: xmldom 0.5.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm xmldom: affected < 0.5.0; fixed in 0.5.0 ## Suggested inspection (read-only) - `npm ls xmldom --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on xmldom. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-h6q6-9hqw-rwfv (OSV record GHSA-h6q6-9hqw-rwfv lists affected ranges: npm xmldom >=0 <0.5.0 (fixed)) - Verified: https://github.com/advisories/GHSA-h6q6-9hqw-rwfv (GitHub-reviewed advisory GHSA-h6q6-9hqw-rwfv lists affected ranges: npm xmldom >=0 <0.5.0) Commands are suggestions: review each one before running it.
Loading voting…