Sensitive information disclosure via log in com.bmuschko:gradle-vagrant-plugin
CVE-2021-21361GHSA-jpcm-4485-69p7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.bmuschko:gradle-vagrant-plugin 3.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.bmuschko:gradle-vagrant-plugin
- Affected
- >= 0.6, < 3.0.0
- Fixed in
- 3.0.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jpcm-4485-69p7 lists affected ranges: Maven com.bmuschko:gradle-vagrant-plugin >=0.6 <3.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.4 · CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
- EPSS
- CVE-2021-21361: 1.18% estimated exploitation activity in the next 30 days; percentile 67.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The com.bmuschko:gradle-vagrant-plugin Gradle plugin contains an information disclosure vulnerability due to the logging of the system environment variables. When this Gradle plugin is executed in public CI/CD, this can lead to sensitive credentials being exposed to malicious actors. Patches Fixed in version 3.0.0 References - https://github.com/bmuschko/gradle-vagrant-plugin/blob/292129f9343d00d391543fae06239e9b0f33db73/src/main/groovy/com/bmuschko/gradle/vagrant/process/GDKExternalProcessExecutor.groovy#L42-L44 - https://github.com/bmuschko/gradle-vagrant-plugin/issues/19 - https://github.com/bmuschko/gradle-vagrant-plugin/pull/20 For more information If you have any questions or comments about this advisory: Open an issue in bmuschko/gradle-vagrant-plugin
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-jpcm-4485-69p7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-21361 Advisory: Sensitive information disclosure via log in com.bmuschko:gradle-vagrant-plugin IDs: CVE-2021-21361, GHSA-jpcm-4485-69p7 Record: https://patchnext.com/advisories/cve-2021-21361 (revision 1, source checked 26 Oct 2026, 16:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.bmuschko:gradle-vagrant-plugin 3.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.bmuschko:gradle-vagrant-plugin: affected >= 0.6, < 3.0.0; fixed in 3.0.0 ## Suggested inspection (read-only) - Maven com.bmuschko:gradle-vagrant-plugin: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.bmuschko:gradle-vagrant-plugin. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jpcm-4485-69p7 (GitHub-reviewed advisory GHSA-jpcm-4485-69p7 lists affected ranges: Maven com.bmuschko:gradle-vagrant-plugin >=0.6 <3.0.0) Commands are suggestions: review each one before running it.
Loading voting…