Exposure of Sensitive Information to an Unauthorized Actor in Products.GenericSetup
CVE-2021-21360GHSA-jff3-mwp3-f8cw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (products-genericsetup 2.1.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 2.1.1
- Fixed in
- 2.1.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jff3-mwp3-f8cw lists affected ranges: PyPI products-genericsetup >=0 <2.1.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jff3-mwp3-f8cw lists affected ranges: PyPI products-genericsetup >=0 <2.1.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2021-21360: 1.55% estimated exploitation activity in the next 30 days; percentile 75.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact What kind of vulnerability is it? Who is impacted? Information disclosure vulnerability - anonymous visitors may view log and snapshot files generated by the Generic Setup Tool. Patches Has the problem been patched? What versions should users upgrade to? The problem has been fixed in version 2.1.1. Depending on how you have installed Products.GenericSetup, you should change the buildout version pin to 2.1.1 and re-run the buildout, or if you used pip simply do pip install "Products.GenericSetup=2.1.1" Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? Visit the ZMI Security tab at portalsetup/manageaccess and click on the link Access contents information. On the next page, uncheck the box Also use roles acquired from folders containing this objects at the bottom and check the boxes for Manager and Owner. Then click on Save Changes. Return to the ZMI Security tab at portalsetup/manageaccess and scroll down to the link View. Click on…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-jff3-mwp3-f8cw
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-jff3-mwp3-f8cw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-21360 Advisory: Exposure of Sensitive Information to an Unauthorized Actor in Products.GenericSetup IDs: CVE-2021-21360, GHSA-jff3-mwp3-f8cw Record: https://patchnext.com/advisories/cve-2021-21360 (revision 3, source checked 26 Oct 2026, 13:22 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: products-genericsetup 2.1.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI products-genericsetup: affected < 2.1.1; fixed in 2.1.1 ## Suggested inspection (read-only) - `python -m pip show products-genericsetup`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on products-genericsetup. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jff3-mwp3-f8cw (OSV record GHSA-jff3-mwp3-f8cw lists affected ranges: PyPI products-genericsetup >=0 <2.1.1 (fixed)) - Verified: https://github.com/advisories/GHSA-jff3-mwp3-f8cw (GitHub-reviewed advisory GHSA-jff3-mwp3-f8cw lists affected ranges: PyPI products-genericsetup >=0 <2.1.1) Commands are suggestions: review each one before running it.
Loading voting…