Skip to content

← Actionable
Medium, CVSS 6.8amended

Remote code execution via the pretty option.

CVE-2021-21353GHSA-p493-635q-r6gr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pug 3.0.1; pug-code-gen 3.0.2, 2.0.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm pug

    Affected
    < 3.0.1
    Fixed in
    3.0.1
  • npm pug-code-gen

    Affected
    < 2.0.3>= 3.0.0, < 3.0.2
    Fixed in
    2.0.3, 3.0.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:N/I:H/A:N
EPSS
  • CVE-2021-21353: 4.27% estimated exploitation activity in the next 30 days; percentile 91.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact If a remote attacker was able to control the pretty option of the pug compiler, e.g. if you spread a user provided object such as the query parameters of a request into the pug template inputs, it was possible for them to achieve remote code execution on the node.js backend. Patches Upgrade to pug@3.0.1 or pug-code-gen@3.0.2 or pug-code-gen@2.0.3, which correctly sanitise the parameter. Workarounds If there is no way for un-trusted input to be passed to pug as the pretty option, e.g. if you compile templates in advance before applying user input to them, you do not need to upgrade. References Original report: https://github.com/pugjs/pug/issues/3312 For more information If you believe you have found other vulnerabilities, please DO NOT open an issue. Instead, you can follow the instructions in our Security Policy

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-p493-635q-r6gr

  2. Revision 1 · created ·

    Published from osv record GHSA-p493-635q-r6gr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-21353

Advisory: Remote code execution via the `pretty` option.
IDs: CVE-2021-21353, GHSA-p493-635q-r6gr
Record: https://patchnext.com/advisories/cve-2021-21353 (revision 2, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pug 3.0.1; pug-code-gen 3.0.2, 2.0.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm pug: affected < 3.0.1; fixed in 3.0.1
- npm pug-code-gen: affected < 2.0.3; >= 3.0.0, < 3.0.2; fixed in 2.0.3, 3.0.2

## Suggested inspection (read-only)
- `npm ls pug --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls pug-code-gen --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pug, pug-code-gen.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-p493-635q-r6gr (OSV record GHSA-p493-635q-r6gr lists affected ranges: npm pug >=0 =0 =3.0.0 <3.0.2 (fixed))
- Verified: https://github.com/advisories/GHSA-p493-635q-r6gr (GitHub-reviewed advisory GHSA-p493-635q-r6gr lists affected ranges: npm pug >=0 =0 =3.0.0 <3.0.2)

Commands are suggestions: review each one before running it.

Loading voting…