XStream is vulnerable to an Arbitrary Code Execution attack
CVE-2021-21347GHSA-qpfq-ph7r-qv6f
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.thoughtworks.xstream:xstream 1.4.16), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.thoughtworks.xstream:xstream
- Affected
- < 1.4.16
- Fixed in
- 1.4.16
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qpfq-ph7r-qv6f lists affected ranges: Maven com.thoughtworks.xstream:xstream >=0 <1.4.16
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:N/I:H/A:N
- EPSS
- CVE-2021-21347: 14.30% estimated exploitation activity in the next 30 days; percentile 96.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The vulnerability may allow a remote attacker to load and execute arbitrary code from a remote host only by manipulating the processed input stream. No user is affected, who followed the recommendation to setup XStream's security framework with a whitelist limited to the minimal required types. Patches If you rely on XStream's default blacklist of the Security Framework, you will have to use at least version 1.4.16. Workarounds See workarounds for the different versions covering all CVEs. References See full information about the nature of the vulnerability and the steps to reproduce it in XStream's documentation for CVE-2021-21347. Credits The vulnerability was discovered and reported by threedr3am. For more information If you have any questions or comments about this advisory: Open an issue in XStream Contact us at XStream Google Group
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-qpfq-ph7r-qv6f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-21347 Advisory: XStream is vulnerable to an Arbitrary Code Execution attack IDs: CVE-2021-21347, GHSA-qpfq-ph7r-qv6f Record: https://patchnext.com/advisories/cve-2021-21347 (revision 1, source checked 26 Oct 2026, 16:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.thoughtworks.xstream:xstream 1.4.16. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.thoughtworks.xstream:xstream: affected < 1.4.16; fixed in 1.4.16 ## Suggested inspection (read-only) - Maven com.thoughtworks.xstream:xstream: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.thoughtworks.xstream:xstream. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qpfq-ph7r-qv6f (GitHub-reviewed advisory GHSA-qpfq-ph7r-qv6f lists affected ranges: Maven com.thoughtworks.xstream:xstream >=0 <1.4.16) Commands are suggestions: review each one before running it.
Loading voting…