URL Redirection to Untrusted Site ('Open Redirect') in Products.PluggableAuthService
CVE-2021-21337GHSA-p44j-xrqg-4xrr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (products-pluggableauthservice 2.6.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI products-pluggableauthservice
- Affected
- < 2.6.1
- Fixed in
- 2.6.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-p44j-xrqg-4xrr lists affected ranges: PyPI products-pluggableauthservice >=0 <2.6.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p44j-xrqg-4xrr lists affected ranges: PyPI products-pluggableauthservice >=0 <2.6.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2021-21337: 8.44% estimated exploitation activity in the next 30 days; percentile 95.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact What kind of vulnerability is it? Who is impacted? Open redirect vulnerability - a maliciously crafted link to the login form and login functionality could redirect the browser to a different website. Patches Has the problem been patched? What versions should users upgrade to? The problem has been fixed in version 2.6.1. Depending on how you have installed Products.PluggableAuthService, you should change the buildout version pin to 2.6.1 and re-run the buildout, or if you used pip simply do pip install "Products.PluggableAuthService=2.6.1" Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? There is no workaround. Users are encouraged to upgrade. References Are there any links users can visit to find out more? - GHSA-p44j-xrqg-4xrr - Products.PluggableAuthService on PyPI - OWASP page on open redirects For more information If you have any questions or comments about this advisory: Open an issue in the Products.PluggableAuthService issue…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-p44j-xrqg-4xrr
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-p44j-xrqg-4xrr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-21337
Advisory: URL Redirection to Untrusted Site ('Open Redirect') in Products.PluggableAuthService
IDs: CVE-2021-21337, GHSA-p44j-xrqg-4xrr
Record: https://patchnext.com/advisories/cve-2021-21337 (revision 3, source checked 26 Oct 2026, 13:22 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: products-pluggableauthservice 2.6.1. A vendor fix does not mean a deployment is fixed.
## Affected components
- PyPI products-pluggableauthservice: affected < 2.6.1; fixed in 2.6.1
## Suggested inspection (read-only)
- `python -m pip show products-pluggableauthservice`: prints the installed version. Run with the environment that serves production active.
## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.
## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on products-pluggableauthservice.
- Repeat the inspection and confirm that only fixed versions remain installed.
## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.
## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.
## Sources
- Verified: https://osv.dev/vulnerability/GHSA-p44j-xrqg-4xrr (OSV record GHSA-p44j-xrqg-4xrr lists affected ranges: PyPI products-pluggableauthservice >=0 <2.6.1 (fixed))
- Verified: https://github.com/advisories/GHSA-p44j-xrqg-4xrr (GitHub-reviewed advisory GHSA-p44j-xrqg-4xrr lists affected ranges: PyPI products-pluggableauthservice >=0 <2.6.1)
Commands are suggestions: review each one before running it.Loading voting…