Skip to content

← Actionable
Medium, CVSS 6.3

containerd environment variable leak

CVE-2021-21334GHSA-6g2q-w5j3-fwh4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/containerd/containerd 1.4.4, 1.3.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.3 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:N/A:N
EPSS
  • CVE-2021-21334: 1.95% estimated exploitation activity in the next 30 days; percentile 80.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Containers launched through containerd's CRI implementation (through Kubernetes, crictl, or any other pod/container client that uses the containerd CRI service) that share the same image may receive incorrect environment variables, including values that are defined for other containers. If the affected containers have different security contexts, this may allow sensitive information to be unintentionally shared. If you are not using containerd’s CRI implementation (through one of the mechanisms described above), you are not vulnerable to this issue. If you are not launching multiple containers or Kubernetes pods from the same image which have different environment variables, you are not vulnerable to this issue. If you are not launching multiple containers or Kubernetes pods from the same image in rapid succession, you have reduced likelihood of being vulnerable to this issue Patches This vulnerability has been fixed in containerd 1.3.10 and containerd 1.4.4. Users should…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-6g2q-w5j3-fwh4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-21334

Advisory: containerd environment variable leak
IDs: CVE-2021-21334, GHSA-6g2q-w5j3-fwh4
Record: https://patchnext.com/advisories/cve-2021-21334 (revision 1, source checked 26 Oct 2026, 15:03 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/containerd/containerd 1.4.4, 1.3.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/containerd/containerd: affected >= 1.4.0, < 1.4.4; < 1.3.10; fixed in 1.3.10, 1.4.4

## Suggested inspection (read-only)
- Go github.com/containerd/containerd: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/containerd/containerd.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6g2q-w5j3-fwh4 (GitHub-reviewed advisory GHSA-6g2q-w5j3-fwh4 lists affected ranges: Go github.com/containerd/containerd >=1.4.0 =0 <1.3.10)

Commands are suggestions: review each one before running it.

Loading voting…