HTML injection in email and account expiry notifications
CVE-2021-21333GHSA-c5f8-35qr-q4fm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (matrix-synapse 1.27.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI matrix-synapse
- Affected
- < 1.27.0
- Fixed in
- 1.27.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-c5f8-35qr-q4fm lists affected ranges: PyPI matrix-synapse >=0 <1.27.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c5f8-35qr-q4fm lists affected ranges: PyPI matrix-synapse >=0 <1.27.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 4.9 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:N/SI:H/SA:N · score source
- EPSS
- CVE-2021-21333: 1.35% estimated exploitation activity in the next 30 days; percentile 71.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The notification emails sent for notifications for missed messages or for an expiring account are subject to HTML injection. In the case of the notification for missed messages, this could allow an attacker to insert forged content into the email. The account expiry feature is not enabled by default and the HTML injection is not controllable by an attacker. Patches This issue is fixed in #9200. Workarounds For the missed messages notifications: The notif.html, notifmail.html, and room.html templates can be overridden with custom templates that manually escapes the variables using JInja2's escape filter. See the email.templatedir setting. For the account expiry notifications: 1. Account expiry can be disabled via the accountvalidity.enabled setting. 2. The noticeexpiry.html template can be overridden with a custom template that manually escapes the variables using JInja2's escape filter. See the email.templatedir setting.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-c5f8-35qr-q4fm
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-c5f8-35qr-q4fm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-21333 Advisory: HTML injection in email and account expiry notifications IDs: CVE-2021-21333, GHSA-c5f8-35qr-q4fm Record: https://patchnext.com/advisories/cve-2021-21333 (revision 3, source checked 26 Oct 2026, 13:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: matrix-synapse 1.27.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI matrix-synapse: affected < 1.27.0; fixed in 1.27.0 ## Suggested inspection (read-only) - `python -m pip show matrix-synapse`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on matrix-synapse. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-c5f8-35qr-q4fm (OSV record GHSA-c5f8-35qr-q4fm lists affected ranges: PyPI matrix-synapse >=0 <1.27.0 (fixed)) - Verified: https://github.com/advisories/GHSA-c5f8-35qr-q4fm (GitHub-reviewed advisory GHSA-c5f8-35qr-q4fm lists affected ranges: PyPI matrix-synapse >=0 <1.27.0) Commands are suggestions: review each one before running it.
Loading voting…