Cross-site scripting (XSS) vulnerability in the password reset endpoint
CVE-2021-21332GHSA-246w-56m2-5899
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (matrix-synapse 1.27.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI matrix-synapse
- Affected
- < 1.27.0
- Fixed in
- 1.27.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-246w-56m2-5899 lists affected ranges: PyPI matrix-synapse >=0 <1.27.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-246w-56m2-5899 lists affected ranges: PyPI matrix-synapse >=0 <1.27.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.1 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:H/SI:L/SA:N · score source
- EPSS
- CVE-2021-21332: 1.22% estimated exploitation activity in the next 30 days; percentile 68.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The password reset endpoint served via Synapse was vulnerable to cross-site scripting (XSS) attacks. The impact depends on the configuration of the domain that Synapse is deployed on, but may allow access to cookies and other browser data, CSRF vulnerabilities, and access to other resources served on the same domain or parent domains. Patches This is fixed in #9200. Workarounds Depending on the needs and configuration of the homeserver a few options are available: 1. Password resets can be disabled by delegating email to a third-party service (via the accountthreepiddelegates.email setting) or disabling email (by not configuring the email setting). 2. If the homeserver is not configured to use passwords (via the passwordconfig.enabled setting) then the affected endpoint can be blocked at a reverse proxy: /synapse/client/passwordreset/email/submittoken 3. The passwordresetconfirmation.html template can be overridden with a custom template that manually escapes the variables…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-246w-56m2-5899
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-246w-56m2-5899
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-21332 Advisory: Cross-site scripting (XSS) vulnerability in the password reset endpoint IDs: CVE-2021-21332, GHSA-246w-56m2-5899 Record: https://patchnext.com/advisories/cve-2021-21332 (revision 3, source checked 26 Oct 2026, 13:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: matrix-synapse 1.27.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI matrix-synapse: affected < 1.27.0; fixed in 1.27.0 ## Suggested inspection (read-only) - `python -m pip show matrix-synapse`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on matrix-synapse. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-246w-56m2-5899 (OSV record GHSA-246w-56m2-5899 lists affected ranges: PyPI matrix-synapse >=0 <1.27.0 (fixed)) - Verified: https://github.com/advisories/GHSA-246w-56m2-5899 (GitHub-reviewed advisory GHSA-246w-56m2-5899 lists affected ranges: PyPI matrix-synapse >=0 <1.27.0) Commands are suggestions: review each one before running it.
Loading voting…