Prefix escape
CVE-2021-21321GHSA-qmw8-3v4g-gwj4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (fastify-reply-from 4.0.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 4.0.2
- Fixed in
- 4.0.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-qmw8-3v4g-gwj4 lists affected ranges: npm fastify-reply-from >=0 <4.0.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qmw8-3v4g-gwj4 lists affected ranges: npm fastify-reply-from >=0 <4.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N
- EPSS
- CVE-2021-21321: 1.82% estimated exploitation activity in the next 30 days; percentile 78.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact By crafting a specific URL, it is possible to escape the prefix of the proxied backend service. If the base url of the proxied server is /pub/, a user expect that accessing /priv on the target service would not be possible. Unfortunately, it is. CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N Patches A patch have been submitted by Corey Farrell git@cfware.com, the reporter. All releases after v4.0.2 include the fix. Workarounds There are no workaround available. For more information If you have any questions or comments about this advisory: Open an issue in fastify-reply-from Email us at hello@matteocollina.com
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-qmw8-3v4g-gwj4
- Revision 1 · created ·
Published from osv record GHSA-qmw8-3v4g-gwj4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-21321 Advisory: Prefix escape IDs: CVE-2021-21321, GHSA-qmw8-3v4g-gwj4 Record: https://patchnext.com/advisories/cve-2021-21321 (revision 2, source checked 26 Oct 2026, 12:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 10.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: fastify-reply-from 4.0.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm fastify-reply-from: affected < 4.0.2; fixed in 4.0.2 ## Suggested inspection (read-only) - `npm ls fastify-reply-from --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on fastify-reply-from. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-qmw8-3v4g-gwj4 (OSV record GHSA-qmw8-3v4g-gwj4 lists affected ranges: npm fastify-reply-from >=0 <4.0.2 (fixed)) - Verified: https://github.com/advisories/GHSA-qmw8-3v4g-gwj4 (GitHub-reviewed advisory GHSA-qmw8-3v4g-gwj4 lists affected ranges: npm fastify-reply-from >=0 <4.0.2) Commands are suggestions: review each one before running it.
Loading voting…