Skip to content

← Actionable
High, CVSS 7.2Exploited · CISA KEV

SSRF in adminer

CVE-2021-21311GHSA-x5r2-hj5c-8jx6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vrana/adminer 4.7.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
CVSS
7.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N/E:H
EPSS
  • CVE-2021-21311: 98.46% estimated exploitation activity in the next 30 days; percentile 99.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Users of Adminer versions bundling all drivers (e.g. adminer.php) are affected. Patches Patched by ccd2374b, included in version 4.7.9. Workarounds Use a single driver version (e.g. adminer-mysql.php). Protect access to Adminer also by other means, e.g. by HTTP password, IP address limiting or by OTP plugin. References https://github.com/vrana/adminer/files/5957311/Adminer.SSRF.pdf For more information If you have any questions or comments about this advisory: Comment at ccd2374b.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-x5r2-hj5c-8jx6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-21311

Advisory: SSRF in adminer
IDs: CVE-2021-21311, GHSA-x5r2-hj5c-8jx6
Record: https://patchnext.com/advisories/cve-2021-21311 (revision 1, source checked 26 Oct 2026, 14:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.2)
Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
Vendor response: Vendor fix available; fixed versions by package: vrana/adminer 4.7.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist vrana/adminer: affected < 4.7.9; fixed in 4.7.9

## Suggested inspection (read-only)
- Packagist vrana/adminer: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vrana/adminer.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-x5r2-hj5c-8jx6 (GitHub-reviewed advisory GHSA-x5r2-hj5c-8jx6 lists affected ranges: Packagist vrana/adminer >=0 <4.7.9)
- Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2021-21311 to the Known Exploited Vulnerabilities catalog on 2025-09-29.)

Commands are suggestions: review each one before running it.

Loading voting…