Token verification bug in next-auth
CVE-2021-21310GHSA-pg53-56cg-4m8q
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (next-auth 3.3.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm next-auth
- Affected
- < 3.3.0
- Fixed in
- 3.3.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pg53-56cg-4m8q lists affected ranges: npm next-auth >=0 <3.3.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pg53-56cg-4m8q lists affected ranges: npm next-auth >=0 <3.3.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2021-21310: 1.67% estimated exploitation activity in the next 30 days; percentile 76.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Implementations using the Prisma database adapter with the Email provider are impacted. Implementations using the Prisma database adapter that are not using the Email provider are not impacted. Implementations using the default database adapter (TypeORM) with the Email provider are not impacted. Implementations not using a database are not impacted. Patches This issue is fixed in 3.3.0 and newer versions. Workarounds Those not able to upgrade can alternatively disable the Email provider as a workaround. Description The Prisma database adapter was checking the verification token but not the identifier (the email address associated with the token). This made it possible to use a valid token assigned to one user, to sign in as another user when using the Prima adapter in conjunction with the Email provider. The defect is specific to the community-supported Prisma database adapter in versions <3.3.0 and is not present in the default database adapter (TypeORM). Note: The current…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-pg53-56cg-4m8q
- Revision 1 · created ·
Published from osv record GHSA-pg53-56cg-4m8q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-21310 Advisory: Token verification bug in next-auth IDs: CVE-2021-21310, GHSA-pg53-56cg-4m8q Record: https://patchnext.com/advisories/cve-2021-21310 (revision 2, source checked 26 Oct 2026, 12:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: next-auth 3.3.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm next-auth: affected < 3.3.0; fixed in 3.3.0 ## Suggested inspection (read-only) - `npm ls next-auth --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on next-auth. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-pg53-56cg-4m8q (OSV record GHSA-pg53-56cg-4m8q lists affected ranges: npm next-auth >=0 <3.3.0 (fixed)) - Verified: https://github.com/advisories/GHSA-pg53-56cg-4m8q (GitHub-reviewed advisory GHSA-pg53-56cg-4m8q lists affected ranges: npm next-auth >=0 <3.3.0) Commands are suggestions: review each one before running it.
Loading voting…