Skip to content

← Actionable
High, CVSS 7.4

Code Injection vulnerability in CarrierWave::RMagick

CVE-2021-21305GHSA-cf3w-g86h-35x4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (carrierwave 2.1.1, 1.3.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems carrierwave

    Affected
    < 1.3.2>= 2.0.0, < 2.1.1
    Fixed in
    2.1.1, 1.3.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:L
EPSS
  • CVE-2021-21305: 13.21% estimated exploitation activity in the next 30 days; percentile 96.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact CarrierWave::RMagick has a Code Injection vulnerability. Its #manipulate! method inappropriately evals the content of mutation option(:read/:write), allowing attackers to craft a string that can be executed as a Ruby code. If an application developer supplies untrusted inputs to the option, it will lead to remote code execution(RCE). (But supplying untrusted input to the option itself is dangerous even in absence of this vulnerability, since is prone to DoS vulnerability - attackers can try to consume massive amounts of memory by resizing to a very large dimension) Proof of Concept Patches Upgrade to 2.1.1 or 1.3.2. Workarounds Stop supplying untrusted input to #manipulate!'s mutation option. References Code Injection Software Attack For more information If you have any questions or comments about this advisory: Open an issue in CarrierWave repo Email me at mit.shibuya@gmail.com

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-cf3w-g86h-35x4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-21305

Advisory: Code Injection vulnerability in CarrierWave::RMagick
IDs: CVE-2021-21305, GHSA-cf3w-g86h-35x4
Record: https://patchnext.com/advisories/cve-2021-21305 (revision 1, source checked 26 Oct 2026, 15:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: carrierwave 2.1.1, 1.3.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems carrierwave: affected < 1.3.2; >= 2.0.0, < 2.1.1; fixed in 2.1.1, 1.3.2

## Suggested inspection (read-only)
- RubyGems carrierwave: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on carrierwave.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-cf3w-g86h-35x4 (GitHub-reviewed advisory GHSA-cf3w-g86h-35x4 lists affected ranges: RubyGems carrierwave >=0 =2.0.0 <2.1.1)

Commands are suggestions: review each one before running it.

Loading voting…