Skip to content

← Actionable
Medium, CVSS 4.8

HTTP Request Smuggling in hyper

CVE-2021-21299GHSA-6hfq-h8hq-87mf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (hyper 0.14.3, 0.13.10, 0.12.36), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io hyper

    Affected
    >= 0.14.0, < 0.14.3>= 0.13.0, < 0.13.10>= 0.12.0, < 0.12.36
    Fixed in
    0.14.3, 0.13.10, 0.12.36

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2021-21299: 4.73% estimated exploitation activity in the next 30 days; percentile 91.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary hyper's HTTP server code had a flaw that incorrectly understands some requests with multiple transfer-encoding headers to have a chunked payload, when it should have been rejected as illegal. This combined with an upstream HTTP proxy that understands the request payload boundary differently can result in "request smuggling" or "desync attacks". Vulnerability The flaw was introduced in https://github.com/hyperium/hyper/commit/26417fc24a7d05df538e0f39239b373c5c3d61f6, released in v0.12.0. Consider this example request: This request should be rejected, according to RFC 7230, since it has a Transfer-Encoding header, but after folding, it does not end in chunked. hyper would notice the chunked in the first line, and then check the second line, and thanks to a missing boolean assignment, not set the error condition. hyper would treat the payload as being chunked. By differing from the spec, it is possible to send requests like these to endpoints that have different HTTP…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-6hfq-h8hq-87mf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-21299

Advisory: HTTP Request Smuggling in hyper
IDs: CVE-2021-21299, GHSA-6hfq-h8hq-87mf
Record: https://patchnext.com/advisories/cve-2021-21299 (revision 1, source checked 26 Oct 2026, 15:33 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: hyper 0.14.3, 0.13.10, 0.12.36. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io hyper: affected >= 0.14.0, < 0.14.3; >= 0.13.0, < 0.13.10; >= 0.12.0, < 0.12.36; fixed in 0.14.3, 0.13.10, 0.12.36

## Suggested inspection (read-only)
- crates.io hyper: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on hyper.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6hfq-h8hq-87mf (GitHub-reviewed advisory GHSA-6hfq-h8hq-87mf lists affected ranges: crates.io hyper >=0.14.0 =0.13.0 =0.12.0 <0.12.36)

Commands are suggestions: review each one before running it.

Loading voting…