Command Injection Vulnerability in Mechanize
CVE-2021-21289GHSA-qrqm-fpv6-6r8g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mechanize 2.7.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems mechanize
- Affected
- >= 2.0.0, < 2.7.7
- Fixed in
- 2.7.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qrqm-fpv6-6r8g lists affected ranges: RubyGems mechanize >=2.0.0 <2.7.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:H/A:N
- EPSS
- CVE-2021-21289: 3.55% estimated exploitation activity in the next 30 days; percentile 89.32 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
This security advisory has been created for public disclosure of a Command Injection vulnerability that was responsibly reported by @kyoshidajp (Katsuhiko YOSHIDA). Impact Mechanize = v2.0, < v2.7.7 allows for OS commands to be injected using several classes' methods which implicitly use Ruby's Kernel.open method. Exploitation is possible only if untrusted input is used as a local filename and passed to any of these calls: - Mechanize::CookieJar#load: since v2.0 (see 208e3ed) - Mechanize::CookieJar#saveas: since v2.0 (see 5b776a4) - Mechanize#download: since v2.2 (see dc91667) - Mechanize::Download#save and #save! since v2.1 (see 98b2f51, bd62ff0) - Mechanize::File#save and #saveas: since v2.1 (see 2bf7519) - Mechanize::FileResponse#readbody: since v2.0 (see 01039f5) Patches These vulnerabilities are patched in Mechanize v2.7.7. Workarounds No workarounds are available. We recommend upgrading to v2.7.7 or later. References See…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-qrqm-fpv6-6r8g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-21289 Advisory: Command Injection Vulnerability in Mechanize IDs: CVE-2021-21289, GHSA-qrqm-fpv6-6r8g Record: https://patchnext.com/advisories/cve-2021-21289 (revision 1, source checked 26 Oct 2026, 15:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mechanize 2.7.7. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems mechanize: affected >= 2.0.0, < 2.7.7; fixed in 2.7.7 ## Suggested inspection (read-only) - RubyGems mechanize: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mechanize. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qrqm-fpv6-6r8g (GitHub-reviewed advisory GHSA-qrqm-fpv6-6r8g lists affected ranges: RubyGems mechanize >=2.0.0 <2.7.7) Commands are suggestions: review each one before running it.
Loading voting…