Skip to content

← Actionable
Medium, CVSS 6.5

moby docker daemon crash during image pull of malicious image

CVE-2021-21285GHSA-6fj5-m822-rqx8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/moby/moby 20.10.3, 19.3.15), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
EPSS
  • CVE-2021-21285: 3.33% estimated exploitation activity in the next 30 days; percentile 88.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Pulling an intentionally malformed Docker image manifest crashes the dockerd daemon. Patches Versions 20.10.3 and 19.03.15 contain patches that prevent the daemon from crashing. Credits Maintainers would like to thank Josh Larsen, Ian Coldwater, Duffie Cooley, Rory McCune for working on the vulnerability and Brad Geesaman for responsibly disclosing it to security@docker.com.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-6fj5-m822-rqx8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-21285

Advisory: moby docker daemon crash during image pull of malicious image
IDs: CVE-2021-21285, GHSA-6fj5-m822-rqx8
Record: https://patchnext.com/advisories/cve-2021-21285 (revision 1, source checked 26 Oct 2026, 15:04 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/moby/moby 20.10.3, 19.3.15. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/moby/moby: affected < 19.3.15; >= 20.10.0-beta1, < 20.10.3; fixed in 19.3.15, 20.10.3

## Suggested inspection (read-only)
- Go github.com/moby/moby: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/moby/moby.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-6fj5-m822-rqx8 (GitHub-reviewed advisory GHSA-6fj5-m822-rqx8 lists affected ranges: Go github.com/moby/moby >=0 =20.10.0-beta1 <20.10.3)

Commands are suggestions: review each one before running it.

Loading voting…