Skip to content

← Actionable
High, CVSS 7.5amended

Regular Expression Denial-of-Service in npm schema-inspector

CVE-2021-21267GHSA-f38p-c2gq-4pmr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (schema-inspector 2.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2021-21267: 2.09% estimated exploitation activity in the next 30 days; percentile 81.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact What kind of vulnerability is it? Who is impacted? Email address validation is vulnerable to a denial-of-service attack where some input (for example a@0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.) will freeze the program or web browser page executing the code. This affects any current schema-inspector users using any version to validate email addresses. Users who do not do email validation, and instead do other types of validation (like string min or max length, etc), are not affected. Patches Has the problem been patched? What versions should users upgrade to? Users should upgrade to version 2.0.0, which uses a regex expression that isn't vulnerable to ReDoS. The new regex expression is more limited in what it can check, so it is more flexible than the one used before. Therefore, this was a new major version instead of a new patch version to warn people upgrading that they should make sure the email validation still works for their…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-f38p-c2gq-4pmr

  2. Revision 1 · created ·

    Published from osv record GHSA-f38p-c2gq-4pmr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-21267

Advisory: Regular Expression Denial-of-Service in npm schema-inspector
IDs: CVE-2021-21267, GHSA-f38p-c2gq-4pmr
Record: https://patchnext.com/advisories/cve-2021-21267 (revision 2, source checked 26 Oct 2026, 12:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: schema-inspector 2.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm schema-inspector: affected < 2.0.0; fixed in 2.0.0

## Suggested inspection (read-only)
- `npm ls schema-inspector --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on schema-inspector.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-f38p-c2gq-4pmr (OSV record GHSA-f38p-c2gq-4pmr lists affected ranges: npm schema-inspector >=0 <2.0.0 (fixed))
- Verified: https://github.com/advisories/GHSA-f38p-c2gq-4pmr (GitHub-reviewed advisory GHSA-f38p-c2gq-4pmr lists affected ranges: npm schema-inspector >=0 <2.0.0)

Commands are suggestions: review each one before running it.

Loading voting…