Regular Expression Denial of Service (REDoS) in httplib2
CVE-2021-21240GHSA-93xj-8mrv-444m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (httplib2 0.19.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI httplib2
- Affected
- < 0.19.0
- Fixed in
- 0.19.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-93xj-8mrv-444m lists affected ranges: PyPI httplib2 >=0 <0.19.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-93xj-8mrv-444m lists affected ranges: PyPI httplib2 >=0 <0.19.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2021-21240: 3.67% estimated exploitation activity in the next 30 days; percentile 89.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A malicious server which responds with long series of \xa0 characters in the www-authenticate header may cause Denial of Service (CPU burn while parsing header) of the httplib2 client accessing said server. Patches Version 0.19.0 contains new implementation of auth headers parsing, using pyparsing library. https://github.com/httplib2/httplib2/pull/182 Workarounds Technical Details The vulnerable regular expression is https://github.com/httplib2/httplib2/blob/595e248d0958c00e83cb28f136a2a54772772b50/python3/httplib2/init.py#L336-L338 The section before the equals sign contains multiple overlapping groups. Ignoring the optional part containing a comma, we have: \s[^ \t\r\n=]+\s= Since all three infinitely repeating groups accept the non-breaking space character \xa0, a long string of \xa0 causes catastrophic backtracking. The complexity is cubic, so doubling the length of the malicious string of \xa0 makes processing take 8 times as long. Reproduction Steps Run a malicious…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-93xj-8mrv-444m
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-93xj-8mrv-444m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-21240 Advisory: Regular Expression Denial of Service (REDoS) in httplib2 IDs: CVE-2021-21240, GHSA-93xj-8mrv-444m Record: https://patchnext.com/advisories/cve-2021-21240 (revision 3, source checked 26 Oct 2026, 13:17 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: httplib2 0.19.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI httplib2: affected < 0.19.0; fixed in 0.19.0 ## Suggested inspection (read-only) - `python -m pip show httplib2`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on httplib2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-93xj-8mrv-444m (OSV record GHSA-93xj-8mrv-444m lists affected ranges: PyPI httplib2 >=0 <0.19.0 (fixed)) - Verified: https://github.com/advisories/GHSA-93xj-8mrv-444m (GitHub-reviewed advisory GHSA-93xj-8mrv-444m lists affected ranges: PyPI httplib2 >=0 <0.19.0) Commands are suggestions: review each one before running it.
Loading voting…