Skip to content

← Actionable
High, CVSS 7.2

Git LFS can execute a Git binary from the current directory on Windows

CVE-2021-21237GHSA-cx3w-xqmc-84g5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/git-lfs/git-lfs 2.13.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.2 · CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:N
EPSS
  • CVE-2021-21237: 0.45% estimated exploitation activity in the next 30 days; percentile 39.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact On Windows, if Git LFS operates on a malicious repository with a git.bat or git.exe file in the current directory, that program would be executed, permitting the attacker to execute arbitrary code. This does not affect Unix systems. This is the result of an incomplete fix for CVE-2020-27955. This issue occurs because on Windows, Go includes (and prefers) the current directory when the name of a command run does not contain a directory separator. Patches This version should be patched in v2.13.2, which will be released in coordination with this security advisory. Workarounds Other than avoiding untrusted repositories or using a different operating system, there is no workaround. References Are there any links users can visit to find out more? For more information If you have any questions or comments about this advisory: - Start a discussion in the Git LFS discussion page. - If you cannot open a discussion, please email the core team using their usernames at github.com.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-cx3w-xqmc-84g5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-21237

Advisory: Git LFS can execute a Git binary from the current directory on Windows
IDs: CVE-2021-21237, GHSA-cx3w-xqmc-84g5
Record: https://patchnext.com/advisories/cve-2021-21237 (revision 1, source checked 26 Oct 2026, 14:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/git-lfs/git-lfs 2.13.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/git-lfs/git-lfs: affected < 2.13.2; fixed in 2.13.2

## Suggested inspection (read-only)
- Go github.com/git-lfs/git-lfs: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/git-lfs/git-lfs.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-cx3w-xqmc-84g5 (GitHub-reviewed advisory GHSA-cx3w-xqmc-84g5 lists affected ranges: Go github.com/git-lfs/git-lfs >=0 <2.13.2)

Commands are suggestions: review each one before running it.

Loading voting…