Magento Insufficient Session Expiration
CVE-2021-21032GHSA-4jfq-f8hc-775q
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist magento/project-community-edition
- Affected
- <= 2.0.2
- Fixed in
- no fixed version recorded
Packagist magento/community-edition
- Affected
- >= 2.4.0, < 2.4.1-p1< 2.3.6
- Fixed in
- 2.4.1-p1, 2.3.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4jfq-f8hc-775q lists affected ranges: Packagist magento/community-edition >=2.4.0 =0 =0 <=2.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.6 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L
- EPSS
- CVE-2021-21032: 1.56% estimated exploitation activity in the next 30 days; percentile 75.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Magento versions 2.4.1 (and earlier), 2.4.0-p1 (and earlier) and 2.3.6 (and earlier) do not adequately invalidate user sessions. Successful exploitation of this issue could lead to unauthorized access to restricted resources. Access to the admin console is not required for successful exploitation.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4jfq-f8hc-775q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-21032 Advisory: Magento Insufficient Session Expiration IDs: CVE-2021-21032, GHSA-4jfq-f8hc-775q Record: https://patchnext.com/advisories/cve-2021-21032 (revision 1, source checked 26 Oct 2026, 14:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: magento/community-edition 2.4.1-p1, 2.3.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist magento/project-community-edition: affected <= 2.0.2 - Packagist magento/community-edition: affected >= 2.4.0, < 2.4.1-p1; < 2.3.6; fixed in 2.4.1-p1, 2.3.6 ## Suggested inspection (read-only) - Packagist magento/project-community-edition: check the installed version with your package manager. - Packagist magento/community-edition: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on magento/project-community-edition, magento/community-edition. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4jfq-f8hc-775q (GitHub-reviewed advisory GHSA-4jfq-f8hc-775q lists affected ranges: Packagist magento/community-edition >=2.4.0 =0 =0 <=2.0.2) Commands are suggestions: review each one before running it.
Loading voting…