Reflected Cross-site Scripting in ACS Commons
CVE-2021-21028GHSA-f92j-qf46-p6vm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.adobe.acs:acs-aem-commons 4.10.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.adobe.acs:acs-aem-commons
- Affected
- < 4.10.0
- Fixed in
- 4.10.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f92j-qf46-p6vm lists affected ranges: Maven com.adobe.acs:acs-aem-commons >=0 <4.10.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2021-21028: 4.12% estimated exploitation activity in the next 30 days; percentile 90.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact ACS Commons version 4.9.2 (and earlier) suffers from a Reflected Cross-site Scripting (XSS) vulnerability in version-compare and page-compare due to invalid JCR characters that are not handled correctly. An attacker could potentially exploit this vulnerability to inject malicious JavaScript content into vulnerable form fields and execute it within the context of the victim's browser. Exploitation of this issue requires user interaction in order to be successful. Patches This issue has been resolved in v4.10.0 Workarounds No workaround exist. References N/A For more information If you have any questions or comments about this advisory open an issue in acs-aem-commons. Credit This issue was discovered and reported by Christopher Whipp (Christopher.Whipp@servicesaustralia.gov.au).
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-f92j-qf46-p6vm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-21028 Advisory: Reflected Cross-site Scripting in ACS Commons IDs: CVE-2021-21028, GHSA-f92j-qf46-p6vm Record: https://patchnext.com/advisories/cve-2021-21028 (revision 1, source checked 26 Oct 2026, 16:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.adobe.acs:acs-aem-commons 4.10.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.adobe.acs:acs-aem-commons: affected < 4.10.0; fixed in 4.10.0 ## Suggested inspection (read-only) - Maven com.adobe.acs:acs-aem-commons: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.adobe.acs:acs-aem-commons. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-f92j-qf46-p6vm (GitHub-reviewed advisory GHSA-f92j-qf46-p6vm lists affected ranges: Maven com.adobe.acs:acs-aem-commons >=0 <4.10.0) Commands are suggestions: review each one before running it.
Loading voting…