Exposure of Sensitive Information to an Unauthorized Actor in MongoDB Rust Driver
CVE-2021-20332GHSA-4rjr-3gj2-5crq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mongodb 2.0.0-beta), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io mongodb
- Affected
- >= 1.0.0, <= 2.0.0-alpha1
- Fixed in
- 2.0.0-beta
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4rjr-3gj2-5crq lists affected ranges: crates.io mongodb >=1.0.0 <=2.0.0-alpha1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.4 · CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2021-20332: 0.31% estimated exploitation activity in the next 30 days; percentile 23.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Specific MongoDB Rust Driver versions can include credentials used by the connection pool to authenticate connections in the monitoring event that is emitted when the pool is created. The user's logging infrastructure could then potentially ingest these events and unexpectedly leak the credentials. Note that such monitoring is not enabled by default.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4rjr-3gj2-5crq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-20332 Advisory: Exposure of Sensitive Information to an Unauthorized Actor in MongoDB Rust Driver IDs: CVE-2021-20332, GHSA-4rjr-3gj2-5crq Record: https://patchnext.com/advisories/cve-2021-20332 (revision 1, source checked 26 Oct 2026, 15:33 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mongodb 2.0.0-beta. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io mongodb: affected >= 1.0.0, <= 2.0.0-alpha1; fixed in 2.0.0-beta ## Suggested inspection (read-only) - crates.io mongodb: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mongodb. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4rjr-3gj2-5crq (GitHub-reviewed advisory GHSA-4rjr-3gj2-5crq lists affected ranges: crates.io mongodb >=1.0.0 <=2.0.0-alpha1) Commands are suggestions: review each one before running it.
Loading voting…