mongodb-client-encryption vulnerable to Improper Certificate Validation
CVE-2021-20327GHSA-rjmf-p882-645m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mongodb-client-encryption 1.2.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 1.2.0, <= 1.2.0
- Fixed in
- 1.2.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-rjmf-p882-645m lists affected ranges: npm mongodb-client-encryption >=1.2.0 <1.2.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rjmf-p882-645m lists affected ranges: npm mongodb-client-encryption >=1.2.0 <=1.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.8 · CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2021-20327: 0.20% estimated exploitation activity in the next 30 days; percentile 10.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A specific version of the Node.js mongodb-client-encryption module does not perform correct validation of the KMS server’s certificate. This vulnerability in combination with a privileged network position active MITM attack could result in interception of traffic between the Node.js driver and the KMS service rendering client-side field level encryption (CSFLE) ineffective. This issue was discovered during internal testing and affects mongodb-client-encryption module version 1.2.0, which was available from 2021-Jan-29 and deprecated in the NPM Registry on 2021-Feb-04. This vulnerability does not impact driver traffic payloads with CSFLE-supported key services from applications residing inside the AWS, GCP, and Azure nework fabrics due to compensating controls in these environments. This issue does not impact driver workloads that don’t use Field Level Encryption. This issue affect MongoDB Node.js Driver mongodb-client-encryption module version 1.2.0
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-rjmf-p882-645m
- Revision 1 · created ·
Published from osv record GHSA-rjmf-p882-645m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-20327 Advisory: mongodb-client-encryption vulnerable to Improper Certificate Validation IDs: CVE-2021-20327, GHSA-rjmf-p882-645m Record: https://patchnext.com/advisories/cve-2021-20327 (revision 2, source checked 26 Oct 2026, 12:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mongodb-client-encryption 1.2.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm mongodb-client-encryption: affected >= 1.2.0, <= 1.2.0; fixed in 1.2.1 ## Suggested inspection (read-only) - `npm ls mongodb-client-encryption --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mongodb-client-encryption. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-rjmf-p882-645m (OSV record GHSA-rjmf-p882-645m lists affected ranges: npm mongodb-client-encryption >=1.2.0 <1.2.1 (fixed)) - Verified: https://github.com/advisories/GHSA-rjmf-p882-645m (GitHub-reviewed advisory GHSA-rjmf-p882-645m lists affected ranges: npm mongodb-client-encryption >=1.2.0 <=1.2.0) Commands are suggestions: review each one before running it.
Loading voting…