Cross-site Scripting in Keycloak
CVE-2021-20323GHSA-xpgc-j48j-jwv9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.keycloak:keycloak-core 17.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.keycloak:keycloak-core
- Affected
- >= 15.0.0, < 17.0.0
- Fixed in
- 17.0.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xpgc-j48j-jwv9 lists affected ranges: Maven org.keycloak:keycloak-core >=15.0.0 <17.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2021-20323: 37.25% estimated exploitation activity in the next 30 days; percentile 98.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A POST based reflected Cross Site Scripting vulnerability on has been identified in Keycloak version 15. The issue was fixed in version 17.0.0.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-xpgc-j48j-jwv9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-20323 Advisory: Cross-site Scripting in Keycloak IDs: CVE-2021-20323, GHSA-xpgc-j48j-jwv9 Record: https://patchnext.com/advisories/cve-2021-20323 (revision 1, source checked 26 Oct 2026, 15:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.keycloak:keycloak-core 17.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.keycloak:keycloak-core: affected >= 15.0.0, < 17.0.0; fixed in 17.0.0 ## Suggested inspection (read-only) - Maven org.keycloak:keycloak-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.keycloak:keycloak-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-xpgc-j48j-jwv9 (GitHub-reviewed advisory GHSA-xpgc-j48j-jwv9 lists affected ranges: Maven org.keycloak:keycloak-core >=15.0.0 <17.0.0) Commands are suggestions: review each one before running it.
Loading voting…