keycloak Self Stored Cross-site Scripting vulnerability
CVE-2021-20195GHSA-q6w2-89hq-hq27
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.keycloak:keycloak-core 13.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.keycloak:keycloak-core
- Affected
- < 13.0.0
- Fixed in
- 13.0.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q6w2-89hq-hq27 lists affected ranges: Maven org.keycloak:keycloak-core >=0 <13.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
- EPSS
- CVE-2021-20195: 1.25% estimated exploitation activity in the next 30 days; percentile 69.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A flaw was found in keycloak in versions before 13.0.0. A Self Stored XSS attack vector escalating to a complete account takeover is possible due to user-supplied data fields not being properly encoded and Javascript code being used to process the data. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-q6w2-89hq-hq27
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-20195 Advisory: keycloak Self Stored Cross-site Scripting vulnerability IDs: CVE-2021-20195, GHSA-q6w2-89hq-hq27 Record: https://patchnext.com/advisories/cve-2021-20195 (revision 1, source checked 26 Oct 2026, 16:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.keycloak:keycloak-core 13.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.keycloak:keycloak-core: affected < 13.0.0; fixed in 13.0.0 ## Suggested inspection (read-only) - Maven org.keycloak:keycloak-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.keycloak:keycloak-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-q6w2-89hq-hq27 (GitHub-reviewed advisory GHSA-q6w2-89hq-hq27 lists affected ranges: Maven org.keycloak:keycloak-core >=0 <13.0.0) Commands are suggestions: review each one before running it.
Loading voting…