Skip to content

← Actionable
High, CVSS 7.2

Moodle Arbitrary PHP code execution by site admins via Shibboleth configuration

CVE-2021-20187GHSA-2jrm-gww7-wch2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (moodle/moodle 3.10.1, 3.9.4, 3.8.7, 3.5.16), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist moodle/moodle

    Affected
    >= 3.5, < 3.5.16>= 3.8, < 3.8.7>= 3.9, < 3.9.4>= 3.10, < 3.10.1
    Fixed in
    3.8.7, 3.5.16, 3.9.4, 3.10.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.2 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2021-20187: 1.59% estimated exploitation activity in the next 30 days; percentile 75.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

It was found in Moodle before version 3.10.1, 3.9.4, 3.8.7 and 3.5.16 that it was possible for site administrators to execute arbitrary PHP scripts via a PHP include used during Shibboleth authentication.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-2jrm-gww7-wch2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-20187

Advisory: Moodle Arbitrary PHP code execution by site admins via Shibboleth configuration
IDs: CVE-2021-20187, GHSA-2jrm-gww7-wch2
Record: https://patchnext.com/advisories/cve-2021-20187 (revision 1, source checked 26 Oct 2026, 14:19 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: moodle/moodle 3.10.1, 3.9.4, 3.8.7, 3.5.16. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist moodle/moodle: affected >= 3.5, < 3.5.16; >= 3.8, < 3.8.7; >= 3.9, < 3.9.4; >= 3.10, < 3.10.1; fixed in 3.8.7, 3.5.16, 3.9.4, 3.10.1

## Suggested inspection (read-only)
- Packagist moodle/moodle: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on moodle/moodle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2jrm-gww7-wch2 (GitHub-reviewed advisory GHSA-2jrm-gww7-wch2 lists affected ranges: Packagist moodle/moodle >=3.5 =3.8 =3.9 =3.10 <3.10.1)

Commands are suggestions: review each one before running it.

Loading voting…