Skip to content

← Actionable
High, CVSS 7.5

Magento authorization bypass vulnerability

CVE-2020-9587GHSA-8wm7-h2qh-ff4c

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist magento/project-community-edition

    Affected
    <= 2.0.2
    Fixed in
    no fixed version recorded
  • Packagist magento/core

    Affected
    < 1.9.4.5
    Fixed in
    1.9.4.5
  • Packagist magento/community-edition

    Affected
    <= 2.2.11>= 2.3.0, < 2.3.4-p2
    Fixed in
    2.3.4-p2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2020-9587: 5.01% estimated exploitation activity in the next 30 days; percentile 92.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Magento versions 2.3.4 and earlier, 2.2.11 and earlier (see note), 1.14.4.4 and earlier, and 1.9.4.4 and earlier have an authorization bypass vulnerability. Successful exploitation could lead to potentially unauthorized product discounts.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-8wm7-h2qh-ff4c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-9587

Advisory: Magento authorization bypass vulnerability
IDs: CVE-2020-9587, GHSA-8wm7-h2qh-ff4c
Record: https://patchnext.com/advisories/cve-2020-9587 (revision 1, source checked 26 Oct 2026, 14:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: magento/core 1.9.4.5; magento/community-edition 2.3.4-p2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist magento/project-community-edition: affected <= 2.0.2
- Packagist magento/core: affected < 1.9.4.5; fixed in 1.9.4.5
- Packagist magento/community-edition: affected <= 2.2.11; >= 2.3.0, < 2.3.4-p2; fixed in 2.3.4-p2

## Suggested inspection (read-only)
- Packagist magento/project-community-edition: check the installed version with your package manager.
- Packagist magento/core: check the installed version with your package manager.
- Packagist magento/community-edition: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on magento/project-community-edition, magento/core, magento/community-edition.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8wm7-h2qh-ff4c (GitHub-reviewed advisory GHSA-8wm7-h2qh-ff4c lists affected ranges: Packagist magento/community-edition >=0 =2.3.0 =0 =0 <=2.0.2)

Commands are suggestions: review each one before running it.

Loading voting…