Improper Authentication in Apache Spark
CVE-2020-9480GHSA-wgx7-jwwm-cgjv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.spark:spark-parent_2.11 2.4.6; pyspark 2.4.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.spark:spark-parent_2.11
- Affected
- <= 2.4.5
- Fixed in
- 2.4.6
PyPI pyspark
- Affected
- < 2.4.6
- Fixed in
- 2.4.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-wgx7-jwwm-cgjv lists affected ranges: Maven org.apache.spark:spark-parent_2.11 >=0 =0 <2.4.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wgx7-jwwm-cgjv lists affected ranges: Maven org.apache.spark:spark-parent_2.11 >=0 =0 <2.4.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2020-9480: 29.37% estimated exploitation activity in the next 30 days; percentile 98.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In Apache Spark 2.4.5 and earlier, a standalone resource manager's master may be configured to require authentication (spark.authenticate) via a shared secret. When enabled, however, a specially-crafted RPC to the master can succeed in starting an application's resources on the Spark cluster, even without the shared key. This can be leveraged to execute shell commands on the host machine. This does not affect Spark clusters using other resource managers (YARN, Mesos, etc).
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-wgx7-jwwm-cgjv
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-wgx7-jwwm-cgjv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-9480 Advisory: Improper Authentication in Apache Spark IDs: CVE-2020-9480, GHSA-wgx7-jwwm-cgjv Record: https://patchnext.com/advisories/cve-2020-9480 (revision 3, source checked 26 Oct 2026, 13:22 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.spark:spark-parent_2.11 2.4.6; pyspark 2.4.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.spark:spark-parent_2.11: affected <= 2.4.5; fixed in 2.4.6 - PyPI pyspark: affected < 2.4.6; fixed in 2.4.6 ## Suggested inspection (read-only) - Maven org.apache.spark:spark-parent_2.11: check the installed version with your package manager. - `python -m pip show pyspark`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.spark:spark-parent_2.11, pyspark. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-wgx7-jwwm-cgjv (OSV record GHSA-wgx7-jwwm-cgjv lists affected ranges: Maven org.apache.spark:spark-parent_2.11 >=0 =0 <2.4.6 (fixed)) - Verified: https://github.com/advisories/GHSA-wgx7-jwwm-cgjv (GitHub-reviewed advisory GHSA-wgx7-jwwm-cgjv lists affected ranges: Maven org.apache.spark:spark-parent_2.11 >=0 =0 <2.4.6) Commands are suggestions: review each one before running it.
Loading voting…