Skip to content

← Actionable
Medium, CVSS 5.4

Silverstripe CMS XSS Vulnerability

CVE-2020-9311GHSA-2pw2-qpcp-m47x

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist silverstripe/cms

    Affected
    <= 4.5.0
    Fixed in
    no fixed version recorded
  • Packagist silverstripe/framework

    Affected
    >= 3.0.0, < 3.7.5
    Fixed in
    3.7.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2020-9311: 0.56% estimated exploitation activity in the next 30 days; percentile 46.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In SilverStripe through 4.5, malicious users with a valid Silverstripe CMS login (usually CMS access) can craft profile information which can lead to XSS for other users through specially crafted login form URLs.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-2pw2-qpcp-m47x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-9311

Advisory: Silverstripe CMS XSS Vulnerability
IDs: CVE-2020-9311, GHSA-2pw2-qpcp-m47x
Record: https://patchnext.com/advisories/cve-2020-9311 (revision 1, source checked 26 Oct 2026, 14:15 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: silverstripe/framework 3.7.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist silverstripe/cms: affected <= 4.5.0
- Packagist silverstripe/framework: affected >= 3.0.0, < 3.7.5; fixed in 3.7.5

## Suggested inspection (read-only)
- Packagist silverstripe/cms: check the installed version with your package manager.
- Packagist silverstripe/framework: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on silverstripe/cms, silverstripe/framework.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2pw2-qpcp-m47x (GitHub-reviewed advisory GHSA-2pw2-qpcp-m47x lists affected ranges: Packagist silverstripe/cms >=0 =3.0.0 <3.7.5)

Commands are suggestions: review each one before running it.

Loading voting…