Skip to content

← Actionable
High, CVSS 7.5

SilverStripe Folders migrated from 3.x may be unsafe to upload to

CVE-2020-9280GHSA-592m-4533-rxq9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (silverstripe/userforms 5.4.2; silverstripe/assets 1.5.2, 1.4.7; silverstripe/framework 4.4.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2020-9280: 1.73% estimated exploitation activity in the next 30 days; percentile 77.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In SilverStripe through 4.5, files uploaded via Forms to folders migrated from Silverstripe CMS 3.x may be put to the default "/Uploads" folder instead. This affects installations which allowed upload folder protection via the optional silverstripe/secureassets module under 3.x. This module is installed and enabled by default on the Common Web Platform (CWP). The vulnerability only affects files uploaded after an upgrade to 4.x.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-592m-4533-rxq9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-9280

Advisory: SilverStripe Folders migrated from 3.x may be unsafe to upload to
IDs: CVE-2020-9280, GHSA-592m-4533-rxq9
Record: https://patchnext.com/advisories/cve-2020-9280 (revision 1, source checked 26 Oct 2026, 14:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: silverstripe/userforms 5.4.2; silverstripe/assets 1.5.2, 1.4.7; silverstripe/framework 4.4.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist silverstripe/userforms: affected >= 5.0.0, < 5.4.2; fixed in 5.4.2
- Packagist silverstripe/assets: affected >= 1.0.0, < 1.4.7; >= 1.5.0, < 1.5.2; fixed in 1.5.2, 1.4.7
- Packagist silverstripe/framework: affected >= 4.0.0, < 4.4.6; fixed in 4.4.6

## Suggested inspection (read-only)
- Packagist silverstripe/userforms: check the installed version with your package manager.
- Packagist silverstripe/assets: check the installed version with your package manager.
- Packagist silverstripe/framework: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on silverstripe/userforms, silverstripe/assets, silverstripe/framework.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-592m-4533-rxq9 (GitHub-reviewed advisory GHSA-592m-4533-rxq9 lists affected ranges: Packagist silverstripe/framework >=4.0.0 =5.0.0 =1.0.0 =1.5.0 <1.5.2)

Commands are suggestions: review each one before running it.

Loading voting…