Privilege Escalation in Kubernetes
CVE-2020-8559GHSA-33c5-9fx5-fvjm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (k8s.io/kubernetes 1.18.7, 1.17.9, 1.16.13; k8s.io/apimachinery 0.18.7, 0.17.9, 0.16.13), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 1.16.13>= 1.17.0, < 1.17.9>= 1.18.0, < 1.18.7
- Fixed in
- 1.18.7, 1.16.13, 1.17.9
- Affected
- < 0.16.13>= 0.17.0, < 0.17.9>= 0.18.0, < 0.18.7
- Fixed in
- 0.16.13, 0.17.9, 0.18.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-33c5-9fx5-fvjm lists affected ranges: Go k8s.io/apimachinery >=0 =0.17.0 =0.18.0 =0 =1.17.0 =1.18.0 <1.18.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.8 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2020-8559: 6.10% estimated exploitation activity in the next 30 days; percentile 93.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The Kubernetes kube-apiserver in versions v1.6-v1.15, and versions prior to v1.16.13, v1.17.9 and v1.18.7 are vulnerable to an unvalidated redirect on proxied upgrade requests that could allow an attacker to escalate privileges from a node compromise to a full cluster compromise.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-33c5-9fx5-fvjm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-8559 Advisory: Privilege Escalation in Kubernetes IDs: CVE-2020-8559, GHSA-33c5-9fx5-fvjm Record: https://patchnext.com/advisories/cve-2020-8559 (revision 1, source checked 26 Oct 2026, 15:04 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: k8s.io/kubernetes 1.18.7, 1.17.9, 1.16.13; k8s.io/apimachinery 0.18.7, 0.17.9, 0.16.13. A vendor fix does not mean a deployment is fixed. ## Affected components - Go k8s.io/kubernetes: affected < 1.16.13; >= 1.17.0, < 1.17.9; >= 1.18.0, < 1.18.7; fixed in 1.18.7, 1.16.13, 1.17.9 - Go k8s.io/apimachinery: affected < 0.16.13; >= 0.17.0, < 0.17.9; >= 0.18.0, < 0.18.7; fixed in 0.16.13, 0.17.9, 0.18.7 ## Suggested inspection (read-only) - Go k8s.io/kubernetes: check the installed version with your package manager. - Go k8s.io/apimachinery: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on k8s.io/kubernetes, k8s.io/apimachinery. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-33c5-9fx5-fvjm (GitHub-reviewed advisory GHSA-33c5-9fx5-fvjm lists affected ranges: Go k8s.io/apimachinery >=0 =0.17.0 =0.18.0 =0 =1.17.0 =1.18.0 <1.18.7) Commands are suggestions: review each one before running it.
Loading voting…