Improper Authentication in Kubernetes
CVE-2020-8558GHSA-wqv3-8cm6-h6wg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (k8s.io/kubernetes 1.18.4, 1.17.7, 1.16.11), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 1.18.0, < 1.18.4>= 1.17.0, < 1.17.7< 1.16.11
- Fixed in
- 1.17.7, 1.16.11, 1.18.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wqv3-8cm6-h6wg lists affected ranges: Go k8s.io/kubernetes >=1.18.0 =1.17.0 =0 <1.16.11
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2020-8558: 3.42% estimated exploitation activity in the next 30 days; percentile 88.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A security issue was discovered in the Kubelet and kube-proxy components of Kubernetes which allows adjacent hosts to reach TCP and UDP services bound to 127.0.0.1 running on the node or in the node's network namespace. For example, if a cluster administrator runs a TCP service on a node that listens on 127.0.0.1:1234, because of this bug, that service would be potentially reachable by other hosts on the same LAN as the node, or by containers running on the same node as the service. If the example service on port 1234 required no additional authentication (because it assumed that only other localhost processes could reach it), then it could be vulnerable to attacks that make use of this bug.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-wqv3-8cm6-h6wg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-8558 Advisory: Improper Authentication in Kubernetes IDs: CVE-2020-8558, GHSA-wqv3-8cm6-h6wg Record: https://patchnext.com/advisories/cve-2020-8558 (revision 1, source checked 26 Oct 2026, 14:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: k8s.io/kubernetes 1.18.4, 1.17.7, 1.16.11. A vendor fix does not mean a deployment is fixed. ## Affected components - Go k8s.io/kubernetes: affected >= 1.18.0, < 1.18.4; >= 1.17.0, < 1.17.7; < 1.16.11; fixed in 1.17.7, 1.16.11, 1.18.4 ## Suggested inspection (read-only) - Go k8s.io/kubernetes: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on k8s.io/kubernetes. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-wqv3-8cm6-h6wg (GitHub-reviewed advisory GHSA-wqv3-8cm6-h6wg lists affected ranges: Go k8s.io/kubernetes >=1.18.0 =1.17.0 =0 <1.16.11) Commands are suggestions: review each one before running it.
Loading voting…