Remote Memory Exposure in bl
CVE-2020-8244GHSA-pp7h-53gx-mx7r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (bl 4.0.3, 3.0.1, 2.2.1, 1.2.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm bl
- Affected
- >= 3.0.0, <= 3.0.0>= 4.0.0, < 4.0.3< 1.2.3>= 2.0.0, < 2.2.1
- Fixed in
- 1.2.3, 3.0.1, 4.0.3, 2.2.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pp7h-53gx-mx7r lists affected ranges: npm bl >=0 =2.0.0 =3.0.0 =4.0.0 <4.0.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pp7h-53gx-mx7r lists affected ranges: npm bl >=3.0.0 =4.0.0 =0 =2.0.0 <2.2.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L
- EPSS
- CVE-2020-8244: 2.10% estimated exploitation activity in the next 30 days; percentile 81.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A buffer over-read vulnerability exists in bl <4.0.3, <3.0.1, <2.2.1, and <1.2.3 which could allow an attacker to supply user input (even typed) that if it ends up in consume() argument and can become negative, the BufferList state can be corrupted, tricking it into exposing uninitialized memory via regular .slice() calls.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-pp7h-53gx-mx7r
- Revision 1 · created ·
Published from osv record GHSA-pp7h-53gx-mx7r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-8244 Advisory: Remote Memory Exposure in bl IDs: CVE-2020-8244, GHSA-pp7h-53gx-mx7r Record: https://patchnext.com/advisories/cve-2020-8244 (revision 2, source checked 26 Oct 2026, 12:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: bl 4.0.3, 3.0.1, 2.2.1, 1.2.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm bl: affected >= 3.0.0, <= 3.0.0; >= 4.0.0, < 4.0.3; < 1.2.3; >= 2.0.0, < 2.2.1; fixed in 1.2.3, 3.0.1, 4.0.3, 2.2.1 ## Suggested inspection (read-only) - `npm ls bl --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on bl. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-pp7h-53gx-mx7r (OSV record GHSA-pp7h-53gx-mx7r lists affected ranges: npm bl >=0 =2.0.0 =3.0.0 =4.0.0 <4.0.3 (fixed)) - Verified: https://github.com/advisories/GHSA-pp7h-53gx-mx7r (GitHub-reviewed advisory GHSA-pp7h-53gx-mx7r lists affected ranges: npm bl >=3.0.0 =4.0.0 =0 =2.0.0 <2.2.1) Commands are suggestions: review each one before running it.
Loading voting…