Skip to content

← Actionable
Medium, CVSS 5.8

phpBB Server-Side Request Forgery Vulnerability

CVE-2020-8226GHSA-jhm9-h84h-rw83

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpbb/phpbb 3.3.1, 3.2.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist phpbb/phpbb

    Affected
    >= 3.2.0, < 3.2.10>= 3.3.0, < 3.3.1
    Fixed in
    3.2.10, 3.3.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:N
EPSS
  • CVE-2020-8226: 0.97% estimated exploitation activity in the next 30 days; percentile 61.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A vulnerability exists in phpBB <v3.2.10 and <v3.3.1 which allowed remote image dimensions check to be used to SSRF.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jhm9-h84h-rw83

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-8226

Advisory: phpBB Server-Side Request Forgery Vulnerability
IDs: CVE-2020-8226, GHSA-jhm9-h84h-rw83
Record: https://patchnext.com/advisories/cve-2020-8226 (revision 1, source checked 26 Oct 2026, 14:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: phpbb/phpbb 3.3.1, 3.2.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist phpbb/phpbb: affected >= 3.2.0, < 3.2.10; >= 3.3.0, < 3.3.1; fixed in 3.2.10, 3.3.1

## Suggested inspection (read-only)
- Packagist phpbb/phpbb: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on phpbb/phpbb.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jhm9-h84h-rw83 (GitHub-reviewed advisory GHSA-jhm9-h84h-rw83 lists affected ranges: Packagist phpbb/phpbb >=3.2.0 =3.3.0 <3.3.1)

Commands are suggestions: review each one before running it.

Loading voting…