Prototype Pollution in lodash
CVE-2020-8203GHSA-p6mc-m468-83gw
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm lodash.set
- Affected
- >= 3.7.0, <= 4.3.2
- Fixed in
- no fixed version recorded
npm lodash.pick
- Affected
- >= 4.0.0, <= 4.4.0
- Fixed in
- no fixed version recorded
RubyGems lodash-rails
- Affected
- >= 3.7.0, < 4.17.19
- Fixed in
- 4.17.19
npm lodash-es
- Affected
- >= 3.7.0, < 4.17.20
- Fixed in
- 4.17.20
npm lodash
- Affected
- >= 3.7.0, < 4.17.19
- Fixed in
- 4.17.19
npm lodash.updatewith
- Affected
- <= 4.10.2
- Fixed in
- no fixed version recorded
npm lodash.setwith
- Affected
- <= 4.3.2
- Fixed in
- no fixed version recorded
npm lodash.update
- Affected
- <= 4.10.2
- Fixed in
- no fixed version recorded
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-p6mc-m468-83gw lists affected ranges: npm lodash >=3.7.0 =3.7.0 =4.0.0 =3.7.0 =0 =0 =0 =3.7.0 <4.17.19 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p6mc-m468-83gw lists affected ranges: npm lodash >=3.7.0 =3.7.0 =4.0.0 =3.7.0 =0 =0 =0 =3.7.0 <4.17.19
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.4 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:H
- EPSS
- CVE-2020-8203: 5.21% estimated exploitation activity in the next 30 days; percentile 92.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Versions of lodash prior to 4.17.19 are vulnerable to Prototype Pollution. The functions pick, set, setWith, update, updateWith, and zipObjectDeep allow a malicious user to modify the prototype of Object if the property identifiers are user-supplied. Being affected by this issue requires manipulating objects based on user-provided property values or arrays. This vulnerability causes the addition or modification of an existing property that will exist on all objects and may lead to Denial of Service or Code Execution under specific circumstances.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-p6mc-m468-83gw
- Revision 1 · created ·
Published from osv record GHSA-p6mc-m468-83gw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-8203 Advisory: Prototype Pollution in lodash IDs: CVE-2020-8203, GHSA-p6mc-m468-83gw Record: https://patchnext.com/advisories/cve-2020-8203 (revision 2, source checked 26 Oct 2026, 12:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: lodash-rails 4.17.19; lodash-es 4.17.20; lodash 4.17.19. A vendor fix does not mean a deployment is fixed. ## Affected components - npm lodash.set: affected >= 3.7.0, <= 4.3.2 - npm lodash.pick: affected >= 4.0.0, <= 4.4.0 - RubyGems lodash-rails: affected >= 3.7.0, < 4.17.19; fixed in 4.17.19 - npm lodash-es: affected >= 3.7.0, < 4.17.20; fixed in 4.17.20 - npm lodash: affected >= 3.7.0, < 4.17.19; fixed in 4.17.19 - npm lodash.updatewith: affected <= 4.10.2 - npm lodash.setwith: affected <= 4.3.2 - npm lodash.update: affected <= 4.10.2 ## Suggested inspection (read-only) - `npm ls lodash.set --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls lodash.pick --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - RubyGems lodash-rails: check the installed version with your package manager. - `npm ls lodash-es --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls lodash --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls lodash.updatewith --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls lodash.setwith --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls lodash.update --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on lodash.set, lodash.pick, lodash-rails, lodash-es, lodash, lodash.updatewith, lodash.setwith, lodash.update. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-p6mc-m468-83gw (OSV record GHSA-p6mc-m468-83gw lists affected ranges: npm lodash >=3.7.0 =3.7.0 =4.0.0 =3.7.0 =0 =0 =0 =3.7.0 <4.17.19 (fixed)) - Verified: https://github.com/advisories/GHSA-p6mc-m468-83gw (GitHub-reviewed advisory GHSA-p6mc-m468-83gw lists affected ranges: npm lodash >=3.7.0 =3.7.0 =4.0.0 =3.7.0 =0 =0 =0 =3.7.0 <4.17.19) Commands are suggestions: review each one before running it.
Loading voting…