Skip to content

← Actionable
Medium, CVSS 5.5amended

Uncontrolled resource consumption in jpeg-js

CVE-2020-8175GHSA-w7q9-p3jq-fmhm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (jpeg-js 0.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm jpeg-js

    Affected
    < 0.4.0
    Fixed in
    0.4.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.5 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
EPSS
  • CVE-2020-8175: 1.08% estimated exploitation activity in the next 30 days; percentile 65.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Uncontrolled resource consumption in jpeg-js before 0.4.0 may allow attacker to launch denial of service attacks using specially a crafted JPEG image.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-w7q9-p3jq-fmhm

  2. Revision 1 · created ·

    Published from osv record GHSA-w7q9-p3jq-fmhm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-8175

Advisory: Uncontrolled resource consumption in jpeg-js
IDs: CVE-2020-8175, GHSA-w7q9-p3jq-fmhm
Record: https://patchnext.com/advisories/cve-2020-8175 (revision 2, source checked 26 Oct 2026, 12:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: jpeg-js 0.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm jpeg-js: affected < 0.4.0; fixed in 0.4.0

## Suggested inspection (read-only)
- `npm ls jpeg-js --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on jpeg-js.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-w7q9-p3jq-fmhm (OSV record GHSA-w7q9-p3jq-fmhm lists affected ranges: npm jpeg-js >=0 <0.4.0 (fixed))
- Verified: https://github.com/advisories/GHSA-w7q9-p3jq-fmhm (GitHub-reviewed advisory GHSA-w7q9-p3jq-fmhm lists affected ranges: npm jpeg-js >=0 <0.4.0)

Commands are suggestions: review each one before running it.

Loading voting…