Skip to content

← Actionable
Medium, CVSS 6.5

CSRF Vulnerability in rails-ujs

CVE-2020-8167GHSA-xq5j-gw7f-jgj8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (actionview 6.0.3.1, 5.2.4.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems actionview

    Affected
    >= 5.0.0, <= 5.2.4.2>= 6.0.0, <= 6.0.3
    Fixed in
    6.0.3.1, 5.2.4.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
EPSS
  • CVE-2020-8167: 1.49% estimated exploitation activity in the next 30 days; percentile 74.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

There is a vulnerability in rails-ujs that allows attackers to send CSRF tokens to wrong domains. Versions Affected: rails <= 6.0.3 Not affected: Applications which don't use rails-ujs. Fixed Versions: rails = 5.2.4.3, rails = 6.0.3.1 Impact ------ This is a regression of CVE-2015-1840. In the scenario where an attacker might be able to control the href attribute of an anchor tag or the action attribute of a form tag that will trigger a POST action, the attacker can set the href or action to a cross-origin URL, and the CSRF token will be sent. Workarounds ----------- To work around this problem, change code that allows users to control the href attribute of an anchor tag or the action attribute of a form tag to filter the user parameters. For example, code like this: linkto params to code like this: linkto filteredparams def filteredparams

Filter just the parameters that you trust end

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-xq5j-gw7f-jgj8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-8167

Advisory: CSRF Vulnerability in rails-ujs
IDs: CVE-2020-8167, GHSA-xq5j-gw7f-jgj8
Record: https://patchnext.com/advisories/cve-2020-8167 (revision 1, source checked 26 Oct 2026, 15:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: actionview 6.0.3.1, 5.2.4.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems actionview: affected >= 5.0.0, <= 5.2.4.2; >= 6.0.0, <= 6.0.3; fixed in 6.0.3.1, 5.2.4.3

## Suggested inspection (read-only)
- RubyGems actionview: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on actionview.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-xq5j-gw7f-jgj8 (GitHub-reviewed advisory GHSA-xq5j-gw7f-jgj8 lists affected ranges: RubyGems actionview >=5.0.0 =6.0.0 <=6.0.3)

Commands are suggestions: review each one before running it.

Loading voting…